New answers tagged

0

Check this article Magento 2: How to add reindex option to Index Management grid? . You can also download the finished code from github or hungersoft.com


0

I just fixed same issue on my server. Please follow my instruction below: Access to server. cd /var/lib/mysql/Magento ("Magento" is my database name) rm -rf catalogsearch_fulltext_scope1.ibd php bin/magento indexer:reindex catalogsearch_fulltext After that, table "catalogsearch_fulltext_scope1" will be regenerated. Hope this helps someone else.


0

Looks like you're hitting a max limitation for the number of columns in a database table as described here: https://www.percona.com/blog/2011/04/07/innodb-row-size-limitation/ There's an article here: https://stackoverflow.com/questions/15585602/change-limit-for-mysql-row-size-too-large and here: https://serverfault.com/questions/326836/issue-with-maximum-...


4

@Alex In your value list of id's to be managed, the quotes are likely causing the processing to work harder than when you use simply the number to be managed as an INT data type. If you find this suggestion helpful, please consider upvote and accept.


5

And another Answer --- thanks to the Chat with Wilson Hauck: He pointed out, that the quotes might confuse the new optimized in 10.3 I took the full query.sql from above and extracted only the select part: SELECT 2 AS `category_id`, `cp`.`entity_id` AS `product_id`, IF(ccp.product_id IS NOT NULL, ccp.position, 0) AS `position`, IF(ccp.product_id IS NOT ...


1

Rate per Second=RPS - Suggestions to consider for your MariaDB 10.3.18 instance my.cnf [mysqld] section innodb_buffer_pool_size=8G # from 512M to reduce innodb_buffer_pool_reads RPS of ~ 5 innodb_io_capacity=1900 # from 200 to enable higher IOPS to your data devices read_buffer_size=256K # from 128K to reduce handler_read_next RPS of 136,418 ...


2

I would suggest you to create a temporary Table. Only one Column, which is the category entity Id afterwards make an insert statement to insert all entity ids into this tmp table. Afterwards convert the way to big in condition into an Join.


1

Partial answer - better debugging welcome. Turns out that the issue is reproducible with MariaDB 10.3.18 locally as well. According to DevDocs "Magento is also compatible with MySQL NDB Cluster 7.4.*, MariaDB 10.0, 10.1, 10.2, Percona 5.7, and other binary-compatible MySQL technologies." This does not mention 10.3.x


Top 50 recent answers are included