We’re rewarding the question askers & reputations are being recalculated! Read more.

New answers tagged

0

This is for Google Shopping ads. You can go to terminal and run php bin/magento cron:show. Look at the class column and confirm your cron jobs.


1

Go to configuration -> Advance -> System -> Cron (Scheduled Tasks) -> Cron configuration options for group: default. Set Schedule Ahead for field as 1. Please see the below screenshot. And then check it.


1

* * * * * This is the actual way of cron scheduling in magento. You don't have to change it. There are 3 levels of cron scheduling in magento. crontab - that you have used in question the second is from store->configuration->Advance->System->Cron, here you can change the timing when magento will check scheduling in codebase Last level is the ...


0

Have you explored any extensions? Wyomind cron scheduler gives you more control over Magento cron tasks. Get the latest version from the website and not git. The version on the website is newer and has bug fixes.


0

You can set different time for your cron group for execution. Like one group you can execute on every one hour and second group you can execute on every 2-3 hours. For that you need to modify your module crontab.xml file Change schedule tag code for every one hour: <schedule>* */1 * * *</schedule> For two hours: <schedule>* */2 * * *&...


0

1. Open terminal 2. write a command crontab -e 3. write below command * * * * * /usr/bin/php /var/www/html/magento2/bin/magento cron:run 2>&1 | grep -v "Ran jobs by schedule" >> /var/www/html/magento2/var/log/magento.cron.log * * * * * /usr/bin/php /var/www/html/magento2/update/cron.php >> /var/www/html/magento2/var/log/update.cron.log *...


0

Maybe this is your idea. Check cronjob installed in your environment crontab -i You can install cronjob in ubuntu with command sudo apt install cron Install magento cronjob Go to magento workspace and run command line: php bin/magento cron:remove php bin/magento cron:install Check Magento cron is installed in the environment crontab -l Open Mysql ...


1

When you "refresh statistics" for "Bestsellers Report" those tables get populated. Refer magneto doc about reports : https://docs.magento.com/m2/ce/user_guide/reports/product-reports.html


0

Maybe this is your idea, You can check again: Check again connect magento 2 to rabiitmq(php bin/magento queue:consumer:start) Check again process queue:consumer:start is starting(ps aux | grep "queue:consumer:start") Test Rest API with specifying API Copy data to test bulk API with same data, same routers


2

Maybe this is your idea, you should create a configuration: crontab.xml <?xml version="1.0" ?> <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Cron:etc/crontab.xsd"> <group id="default"> <job name="masteringAddItem" instance="Mastering\SampleModule\Cron\...


0

just for info I reinstalled AOE_scheduler and updated Magento and that solved the problem


0

Finally I got solution. Just I enabled cron_consumers_runner from app/etc/env.php. Default cron_consumers_runner is false, Just i changed true. 'cron_consumers_runner' => [ 'cron_run' => true, 'max_messages' => 10000, 'consumers' => [ ] ],


0

Connect to your web server using ssh Locate your current PHP CLI path by run command: which php On my ubuntu server, the output is: /usr/bin/php Open crontab setting by run command: crontab -e The crontab is just like a text file, every line is a job will run with a schedule. For example: The part 45 3 * * * is time schedule. That says the script ...


0

Try in sudo su mode, it solved for me. :)


Top 50 recent answers are included