Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

New answers tagged

0

In root directory have a file composer.json, inner this file exists this code line "require": { "intelipost/magento2-basic": "^1.2", "magento/product-community-edition": "2.3.1" }, Remove modules that you will not use, use command line bellow composer update


0

Remove the following files rm -rf var/cache var/page_cache var/view_preprocessed var/di generated/* After this run these commands to generate the files once again php bin/magento setup:di:compile php bin/magento setup:static-content:deploy Please also ensure that var, pub and generated folders has the correct permissions


2

Try this commands as a root user find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + sudo chown -R <Magento user>:<web server group> .  It seems to be a permission issue only, if the image is not found there you will be getting ...


0

Have you searched stack exchange already? I don't know this plugin but this error sounds very similar to one that can be solved by doing this: https://magento.stackexchange.com/a/237872/70343


0

The problem is, that your MySQL user does not have the permission to drop the trigger, which does the index update after the object is updated. Please provide the full privilege to MySQL user. Let me know if you still getting the error.


0

Here is one alternative you can skip compilation while changing mode php bin/magento deploy:mode:set production -s -s stands for --skip-compilation, it will skip compilation.


1

Found a solution by disabling the Symlinks. Navigate to Stores -> Configuration -> Advanced -> Developer -> Template Settings and set “Allow Symlinks” to “No”. Change Materialization Strategy in magento_root/app/etc/di.xml. Change this: <virtualType name="developerMaterialization" type="Magento\Framework\App\View\Asset\MaterializationStrategy\Factory"&...


1

It seems like permission issue for pub/static So just give necessary permission for pub/static then run your command and of course static content deploy will create a down time as well. As of now run the below command in your root chmod -R 755 pub/static/ or chmod -R 777 pub/static/ EDIT : Run the below command then deploy rm -rf pub/static/...


1

That caused by permission. You can upgrade and deploy again. php bin/magento setup:upgrade php bin/magento setup:static-content:deploy en_GB if it still error, pls run command on root: find app/code lib var generated vendor pub/static pub/media app/etc ( -type d -or -type f ) -exec chmod g+w {} + && chmod o+rwx app/etc/env.php After ...


0

The problem lies in the following line of code: require str_replace('importers', '', dirname(__FILE__)) . 'app/Mage.php'; Please try to use the below code: <?php ini_set('max_execution_time', 93600); ini_set('memory_limit', '4096M'); define('MAGENTO_ROOT', getcwd()); require MAGENTO_ROOT . '/app/Mage.php'; error_reporting(E_ALL); ini_set('...


0

Please follow these steps. Change to your Magento Directory find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + sudo chown -R <Magento User>:<web server group> . chmod u+x bin/magento Once permission is set deploy your files as ...


0

Please try by giving 777 permission to generated and var folder Try after Removing generated folder and var/cahe var/di and var/page_cache and var/view_processed and try it . Will be better if you try on local first instead of directly on live.


0

It was an php configuration issue. Because i'm working locally with vagrant i had to change my user and group in /etc/php-fpm/www.conf file from nginx to vagrant.


0

try to setup magento using ssh command:- php bin/magento setup:install --base-url=http://127.0.0.1/magento2/ --db-host=localhost --db-name=magento --db-user=magento --db-password=magento --admin-firstname=Magento --admin-lastname=User --admin-email=user@example.com --admin-user=admin --admin-password=admin123 --language=en_US --currency=USD --timezone=...


0

I've just leant that Xdebug enabled can stop installation process https://devdocs.magento.com/guides/v2.3/install-gde/trouble/tshoot_install-issues.html


0

Are all the required php extensions installed? https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html Try the php module part of this https://github.com/sjanjic/magento2-check?files=1 check.php <?php error_reporting(E_ALL); ini_set('display_errors', 1); function result($value, $result) { if ($result) { return ...


0

Could be not enough memory. Check this https://devdocs.magento.com/guides/v2.3/install-gde/trouble/php/tshoot_php-set.html


0

Looks like file permission issue, try to install it with 777 permission first. login to to ssh then: sudo chmod -R 777 magento_root_directory As 777 is not correct permission not secured, you can just test installation with it, after this you will have to provide correct permission to all file and folders, please refer below: https://devdocs.magento.com/...


0

I was able to "solve" this error at last by clearing the vendor folder of everything except the .htaccess file and then doing a "composer update" to restore it. Steps were: rm -r vendor/* php composer.phar update php bin/magento setup:upgrade php bin/magento cache:clean rm -R pub/static/* rm -r var/view_preprocessed/* rm -r var/view_preprocessing/* php bin/...


1

Hunk #1 FAILED at 144 means line does not match to the patch. Definitely modified those file that is why refusing to apply the patch. The easy solution is: copy affected file from the core(that magento offer, download from magento) replace this and try to apply the patch again.


0

Double check with your migrating Database Magento 2. Sometimes We didn't change the database name in the data migrating tool. Reinstall fresh Magento instance and correctly add database name in data migrating tool


0

There is a function available in PHP (>=7.3) which checks if a variable is countable is_countable Try it like if (is_countable($bannerGroupData) && count($bannerGroupData) > 0): // Your code endif; If the function is not available, you can use below if (($bannerGroupData instanceof Countable) || is_array($bannerGroupData)) && ...


0

Alhamdulillah, my issues solve I just updating my nodejs, because my nodjs before the old one so im updating sudo npm install -g n sudo n latest Done, I can run $grunt , $grunt exec:mytheme Thanks you all for any sugestion :D


0

Here is process for installing grunt: First Rename files from root directory - package.json.sample into package.json - Gruntfile.js.sample into Gruntfile.js Install NodeJs from https://nodejs.org/ Once you have Node install properly run command: "sudo npm install -g grunt-cli" Go to your project dir. then run command: "sudo npm install grunt --save-dev" ...


0

please check the file "grunt-config.json" file in your project root folder. following code should be there: { "themes": "dev/tools/grunt/configs/local-themes" } Also, please check the location /home/user/www/tutor/dev/tools/grunt/configs There will be the file is "themes.js", please rename it to "local-themes.js" flush the cache Please check now and ...


0

Define Like this :- <theme>: { area: 'frontend', name: '<Vendor>/<theme>', // app/Design/Frontend/Vendor/Theme/ locale: '<language>', files: [ 'css/styles-m', 'css/styles-l' ], dsl: 'less' }


0

Please do not rename this, keep it as default : grunt-config.json.sample Now try again, if not working then add --force after your command


0

I had this same issue and turns out flushing the redis cache fix it for me. From command line: echo 'flushall' | redis-cli -s /path/to/sock Heres the documentation incase you're not using a socket: https://briansnelson.com/Install_Redis_Caching_for_Magento Hope that helps.


0

Admin and CMD line changes 1) run below query delete from flag where flag_code='analytics_previous_base_url'; 2) Go to Store >> Configuration >> General >> Advanced Reporting https://www.screencast.com/t/YEQbaKv9Gh first disabled and do enabled again. 3) Go to Store >> Configuration >> Main Website >> General >&...


0

Please check video and refer magento 2 devdocs, this will help you: https://www.youtube.com/watch?v=2N8jSiNk1io https://devdocs.magento.com/guides/v2.3/advanced-reporting/overview.html https://community.magento.com/t5/Magento-2-x-Technical-Issues/Advanced-Reporting-doesn-t-work-and-there-is-an-error-404/td-p/126904


1

Change if($_GET['from'] == "key") { to if(Mage::app()->getRequest()->getParam('from') == "key") {


2

First of all, check that you are getting "from" key in GET / POST request or not. Also, you can use magento way to get parameters fo get or post a request. $fromVar = $this->getRequest()->getParam("from", false); if ($fromVar == 'key') { //Your logic goes here. }


1

I had the same issue and was investigating it, in our case, the customer had recently moved the site to a new host, the problem in the new host it was caused by ModSecurity: --786c900b-B-- POST /administrator/catalog_rule/promo_catalog/newConditionHtml/form/catalog_rule_formrule_conditions_fieldset_/form_namespace/catalog_rule_form/key/...


0

Facing the same issue: I was using the php7.3 (Which is the main issue). Just downgrade the php version 7.3 to 7.2


0

Please change public function imagePreprocessing($data) to public function imagePreprocessing(array $data). it solved my error, I hope your also.


0

Remove file in KiwiCommerce\CronScheduler\Observer\ProcessCronQueueObserverDefault.inc file and put below code in ProcessCronQueueObserver.php <?php namespace KiwiCommerce\CronScheduler\Observer; use Magento\Framework\App\State; use Magento\Framework\Console\Cli; use Magento\Framework\Event\ObserverInterface; use \Magento\Cron\Model\Schedule; class ...


0

You can fix it by putting a title in resource in acl.xml file: <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Acl/etc/acl.xsd"> <acl> <resources> <resource id="Magento_Backend::admin"> <resource id="Mageplaza_Core::menu" ...


0

Check module.xml file of your last installed extension. This error generally occurs because of this file only.


1

Update Gateway Url of UPS from http to https From “http://www.ups.com/using/services/rave/qcostcgi.cgi” to “https://www.ups.com/using/services/rave/qcostcgi.cgi”. Refer this link What is the current UPS shipping gateway? (outage 2019-01-06)


Top 50 recent answers are included