New answers tagged

0

You need to make sure that you run the commands from your Magento installation directory. grunt clean: mdl grunt exec: mdl grunt less: mdl chmod 0777 -R var/* chmod 0777 -R pub/static/* chmod 0777 -R generated/* Grunt watch To check more on how to integrate less on Magento 2. Please read our blog here. Hope this will help you..!


0

Solution for Porto Theme users in Magento 2.4: Edit (or better extend in your child theme): app/design/frontend/Smartwave/porto/Magento_Theme/layout/default.xml Add the following lines inside <body></body>: <referenceContainer name="footer-container"> <block class="Smartwave\Porto\Block\Template" name=&...


0

I had similar problems with Magento 2.4. So I applied quality patch. More about here: magento quality patches In my case I applied MC-41359. Open terminal (root folder) and type: $ ./vendor/bin/magento-patches apply MC-41359, then run rm -rf var/di/* generated/* var/cache/* var/page_cache/* var/view_preprocessed/* pub/static/* php bin/magento setup:upgrade ...


0

Try this it's working. public function upgrade(SchemaSetupInterface $setup, ModuleContextInterface $context) { $setup->startSetup(); if (version_compare($context->getVersion(), '1.0.1') == -1) { $table = $setup->getTable('table_name'); $setup->getConnection() ->addIndex( $table, $setup->getIdxName( ...


0

For your requirement you need to added the new steps to the checkout with desire functionlity. Generally you need to do the following things. Create the view part of the checkout step component. Add your step to the Checkout page layout. Create mixins for shipping steps (optional). More information you can check this one : https://devdocs.magento.com/...


0

Try using like below require([ 'jquery', 'uiComponent', 'Magento_Ui/js/lib/registry/registry', 'Magento_Ui/js/lib/view/utils/dom-observer', ], function ($) { domObserver = require('Magento_Ui/js/lib/view/utils/dom-observer'); $(document).ready(function(){ domObserver.get('.class-name', function(elem){ $(elem).addClass('test-class'); ...


-1


0

Try to add --ignore-platform-reqs=>1 after your command.


0

I did upgrade 2.3.4 to 2.3.7 just some day ago via below commands. hope it works for you. *)set developer mode php bin/magento -d memory_limit=6G maintenance:enable composer require magento/product-community-edition 2.3.7 --no-update composer require --dev phpunit/phpunit:~6.2.0 friendsofphp/php-cs-fixer:~2.10.1 lusitanian/oauth:~0.8.10 pdepend/pdepend:...


0

You can try the following steps: Remove vendor/* Remove composer.lock Modify composer.json with your target Magento version Run composer update More Detail


0

Source of answer https://community.magento.com/t5/Magento-2-x-Programming/Relationship-in-block-and-template/td-p/459182 Case 1: Single Block & Multiple Templates No this can not be true as at a time only 1 template can be assigned to any block. you can not assign multiple templates to any block. the block template is assigned when its instance is ...


0

Its actually an easy fix - Just close any other Magento admin windows in your browser and refresh cache. Then press ctrl + F5 to force refresh your browser session and try again. In my case, I had one Magento admin window open with Mirakl listings setup, and it wasnt acknowledging the cache refresh that I was doing in a separate window. Everything was going ...


0

Check this section in /etc/varnish/default.vcl sub vcl_deliver You'll notice that some headers were unset e.g. unset resp.http.X-Varnish unset resp.http.X-Magento-Debug; Comment them out if you want to see them in the response headers. Also make sure that you set your Magento 2 environment to 'developer'


Top 50 recent answers are included