New answers tagged

0

You must follow in your admin, Store -> Configuration -> Catalog -> Catalog -> Search Engine Optimization -> Use Categories Path for Product URLs, you must change to No, and you have to make sure that in the Website and Store View is No. After that, you must reindex and refresh the cache.


0

Please try with indexing for catalog search full text data


0

in order to get rid of the object manager you need to move all classes that are needed to the construct method using dependency injection. Please have a look and try this modified code <?php namespace Myvendor\Myprogram\ViewModel; class CatLogic extends \Magento\Framework\View\Element\Template implements \Magento\Framework\View\Element\Block\...


0

First change the current state for the Anchor. eg - If the Anchor is turned off for this category, turn it on and save the category. Then change the product positions and save. bin/magento index:reindex bin/magento cache:clean After confirming your products are correctly positioned. You can revert the Anchor back to its original state.


0

It could be that the content that you are trying to edit is stored in a CMS block. In the category's Display Settings, see if Display Mode is set to "Static block only" or "Static block and products". If so, the static block is set in the category's Content section under Add CMS Block.


0

Open the Magento Admin, Catalog -> Categories page. Select particular Category Check the Content section where you found Description options.


0

You probably didn't took care about the store view in your back office. They could be disabled in default store view, but enabled in specific store view.


0

The problem was from another module, mageplaza catalog permission, one of the module observer was causing the error.


Top 50 recent answers are included