New answers tagged

0

Although magento 1 is obsolete, but I encountered this also ... one fix would be to look in the table catalog_category_entity_varchar , filter by entity_id (=category_id) and delete all rows which have the store_id = 1 (or different from 0). After this every time you will change the url_key of the category the url_rewrite will update the main store url ...


-1

Those all image links are already died. In Magento 1, you save the product photos in file/media/catalog, however in Magento 2, you need to save them in file/pub/media/catalog. Therefore, you got the 404 error, it must has /pub/ on the URL. To resolve it, you have 2 options: Create manually a migration script and custom it. Find experienced migration ...


0

I have found that solutions for my questions.Below define in root .htaccess file inside code use it RewriteRule .* index.php [L] RewriteCond %{QUERY_STRING} ^.*q=hhh.*$ RewriteRule .* /magento231? [R=301,NC,L] RewriteCond %{QUERY_STRING} ^q=123$ RewriteRule ^(index\.php)?$ /magento231/test-category.html [QSD,R=301,L]


0

Ok, after searching long and hard and not finding a solution, I have managed to work out a way to solve this which thankfully works. I disable the problem product, save and duplicate. Delete the problem product. Edit, enable and save duplicate product. With the duplicate product I changed the SKU and URL to the old product's details. If anyone has any ...


Top 50 recent answers are included