Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

New answers tagged

0

Open bin/magento in your preferred file editor and add the following line and save: ini_set('display_errors', 1); // allow PHP errors reporting Run the command again: php bin/magento list it will show error which the cause cli not run


0

Please check the permission of your magentoDirectory. $sudo rm -rf var/cache/* generated/code/* $sudo chmod 777 -R magentoDirectory $sudo chown -R www-data:www-data magentoDirectory $php bin/magento setup:di:compile $php bin/magento cache:clean


0

Disable all custom modules except Magento's core modules: php bin/magento module:status | grep -v Magento | grep -v List | grep -v None | grep -v -e '^$'| xargs php bin/magento module:disable -f


0

I used the below commands and it solves my issue every time. php -f bin/magento setup:upgrade rm -rf pub/static/* rm -rf var/view_preprocessed/* php -f bin/magento setup:static-content:deploy php -f bin/magento cache:clean php -f bin/magento indexer:reindex cd .. chmod 777 -R html


0

Finally I got solution. Just I enabled cron_consumers_runner from app/etc/env.php. Default cron_consumers_runner is false, Just i changed true. 'cron_consumers_runner' => [ 'cron_run' => true, 'max_messages' => 10000, 'consumers' => [ ] ],


0

/bin/magento with ... downloadable:domains:add downloadable:domains:remove downloadable:domains:show


0

Connect to your web server using ssh Locate your current PHP CLI path by run command: which php On my ubuntu server, the output is: /usr/bin/php Open crontab setting by run command: crontab -e The crontab is just like a text file, every line is a job will run with a schedule. For example: The part 45 3 * * * is time schedule. That says the script ...


0

sometimes it will work but 85% of the time it will not and just hang in CLI until I turn off listen for connections in phpstorm. How to prevent Xdebug from locking on running bin/magento cron:run


0

Cleaning the generated files might solve it, try to run these sequence of commands below. Check the server requirements too. php bin/magento deploy:mode:set developer ; rm -rf vendor/* generated/* var/* pub/static/* ; composer install ; php bin/magento setup:upgrade ;


1

This does not accomplish OP's goal of utilizing the Magento CLI, however it does work for usage in automation which is what OP (and myself) was looking to achieve. If your automation has access to the database, we can set the theme by querying the appropriate tables and performing INSERT statements. Set Theme at a global scope: INSERT INTO ...


0

I had a similar issue and found a problem inside the PHP error log. One directory was missed inside the vendor directory.


Top 50 recent answers are included