1

I tried to upgrade Magento 2.2.0 to version 2.2.1 via composer however i received framework error about amazon pay conflict (my amazon pay version is 1.1.4). I'm aware i need to update amazon pay to version 1.2.0 first so i can update Magento to 2.2.1.

So i run commands:

composer require magento/product-community-edition 2.2.1 --no-update

composer require amzn/amazon-payments-magento-2-plugin:^1.2.0 --no-update

composer update

And i got an error:

Problem 1
- Installation request for magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1].
- amzn/amazon-pay-and-login-with-amazon-core-module 1.2.0 requires magento/framework ^100.1.0 -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.9, 100.1.10].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc1].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc2].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc3].
- Can only install one of: magento/framework[101.0.1, 100.1.0].
- Can only install one of: magento/framework[101.0.1, 100.1.1].
- Can only install one of: magento/framework[101.0.1, 100.1.2].
- Can only install one of: magento/framework[101.0.1, 100.1.3].
- Can only install one of: magento/framework[101.0.1, 100.1.4].
- Can only install one of: magento/framework[101.0.1, 100.1.5].
- Can only install one of: magento/framework[101.0.1, 100.1.6].
- Can only install one of: magento/framework[101.0.1, 100.1.7].
- Can only install one of: magento/framework[101.0.1, 100.1.8].
- Can only install one of: magento/framework[101.0.1, 100.2.0-rc20].
- Can only install one of: magento/framework[101.0.1, 100.1.9].
- Can only install one of: magento/framework[100.1.10, 101.0.1].
- magento/product-community-edition 2.2.1 requires magento/framework 101.0.1 -> satisfiable by magento/framework[101.0.1].
- Installation request for amzn/amazon-pay-and-login-with-amazon-core-module 1.2.0 -> satisfiable by amzn/amazon-pay-and-login-with-amazon-core-module[1.2.0].

I think my mistake was to run both updates at the same time, and now when I try to update Amazon Pay with below command to version 1.2.0

Command:

composer require amzn/amazon-payments-magento-2-plugin:^1.2.0

I get Error:

Problem 1
    - The requested package magento/product-community-edition (locked at 2.2.0, required as 2.2.1) is satisfiable by magento/product-community-edition[2.2.0] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Installation request for magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1].
    - amzn/amazon-pay-and-login-with-amazon-core-module 1.2.0 requires magento/framework ^100.1.0 -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.9, 100.1.10].
    - Can only install one of: magento/framework[101.0.1, 100.1.0-rc1].
    - Can only install one of: magento/framework[101.0.1, 100.1.0-rc2].
    - Can only install one of: magento/framework[101.0.1, 100.1.0-rc3].
    - Can only install one of: magento/framework[101.0.1, 100.1.0].
    - Can only install one of: magento/framework[101.0.1, 100.1.1].
    - Can only install one of: magento/framework[101.0.1, 100.1.2].
    - Can only install one of: magento/framework[101.0.1, 100.1.3].
    - Can only install one of: magento/framework[101.0.1, 100.1.4].
    - Can only install one of: magento/framework[101.0.1, 100.1.5].
    - Can only install one of: magento/framework[101.0.1, 100.1.6].
    - Can only install one of: magento/framework[101.0.1, 100.1.7].
    - Can only install one of: magento/framework[101.0.1, 100.1.8].
    - Can only install one of: magento/framework[101.0.1, 100.2.0-rc20].
    - Can only install one of: magento/framework[101.0.1, 100.1.9].
    - Can only install one of: magento/framework[100.1.10, 101.0.1].
    - magento/product-community-edition 2.2.1 requires magento/framework 101.0.1 -> satisfiable by magento/framework[101.0.1].
    - Installation request for amzn/amazon-pay-and-login-with-amazon-core-module 1.2.0 -> satisfiable by amzn/amazon-pay-and-login-with-amazon-core-module[1.2.0].

It looks like it still tries to run both updates at the same time... How can i 'unlock' it and only update Amazon pay to version 1.2.0?

0

I have found solution myself, i have changed Magento version back to current version 2.2.0 in composer.json file in magento root folder

"require": {
        "magento/product-community-edition": "2.2.0"
        "composer/composer": "@alpha",
        "amzn/amazon-payments-magento-2-plugin": "1.2.0",

It stopped Magento from requesting update to version 2.2.1 and i could only update amazon pay after that running simply

composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.