3

I am upgrading magento 2.2.8 store to 2.3.2. I have change version in composer.json "magento/product-community-edition": "2.3.2", and run command composer update then get error

Problem 1 - Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2]. - magento/product-community-edition 2.3.2 requires dotmailer/dotmailer-magento2-extension 3.1.2 -> satisfiable by dotmailer/dotmailer-magento2-extension[3.1.2] but these conflict with your requirements or minimum-stability.

How can getout from this error? Thanks

2

you need to use magento script to upgrade from 2.2 to 2.3.3 https://raw.githubusercontent.com/magento/magento2/2.3/dev/tools/UpgradeScripts/pre_composer_update_2.3.php

or at least you have to run:

composer require magento/product-community-edition=2.3.3 --no-update
composer update
|improve this answer|||||
1

Try this

     composer require magento/product-community-edition=2.3.2 --no-update

     composer update dotmailer/dotmailer-magento2-extension --ignore-platform-reqs
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.