I believe this is due to the recent update to composer, but would appreciate any thoughts...

Trying to update Magento from 2.3.5 to 2.3.6, having just updated to the latest version of composer (2.0.4)

I get the following error:

  • Root composer.json requires magento/product-community-edition 2.3.6 -> satisfiable by magento/product-community-edition[2.3.6].
  • magento/product-community-edition 2.3.6 requires magento/composer ~1.5.0 -> satisfiable by magento/composer[1.5.0, 1.5.1] from composer repo (https://repo.packagist.org) but magento/composer[1.0.2, ..., 1.6.0] from composer repo (https://repo.magento.com) has higher repository priority. The packages with higher priority do not match your constraint and are therefore not installable. See https://getcomposer.org/repoprio for details and assistance.

It sounds like Magento 2.3.6 does not support the latest version of Composer, is this correct? If so, any ideas how to get around this?


1 Answer 1


Workaround achieved by downgrading composer back to version 1.9.0

run composer self-update 1.9.0

  • 2
    You could probably go latest version 1 i.e. 1.10.17 (Nov 20) Commented Nov 2, 2020 at 20:44
  • Thanks, worked like a charm for me
    – cjohansson
    Commented May 18, 2021 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.