Trying to do an update to Magento 2.1.0 via composer and getting this weird error.

Php version is 7.04 running on Ubuntu x64

composer require magento/product-community-edition 2.1.0 --no-update

./composer.json has been updated

composer update

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.0].

- magento/product-community-edition 2.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.0.4) does not satisfy that requirement.

3 Answers 3


There is no magento/product-community-edition 2.1.0 yet. Latest release is magento/product-community-edition 2.1.0-rc3. The wording in magento bulletins and notifications is misleading and tricky. You get the impression that there is a 2.1.0 GA, but there are only Release candidates.

  • 2.1.0 has just been released, but it is not compatible with PHP 7.0.4 because of a bug in that PHP version. This is also what the error message states. Jun 24, 2016 at 6:50
  • @fschmengler are you sure 2.1.0 GA was released? I get this error if I want to update with composer Problem 1 - The requested package magento/product-community-edition 2.1.0 exists as magento/product-community-edition[2.1.0-rc3, 0.42.0-beta7, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.1.0-rc1, 2.1.0-rc2] but these are rejected by your constraint. Jun 24, 2016 at 7:56
  • it was announced at least, I did not try to update yet. If it's not available on repo.magento.com yet, it seems like OP hat a constraint like stability: alpha which made 2.1.0-rc3 match his requirement of 2.1.0. Jun 24, 2016 at 8:03

The PHP version constraints of Magento 2.1 are ~5.6.0|7.0.2|~7.0.6 as shown in the error message. That means, it is compatible with all patch versions of PHP 5.6, with PHP 7.0.2 and with PHP 7.0 versions >= 7.0.6

The gap comes from some bugs in PHP 7.0.3-7.0.5 that caused problems with Magento and are fixed in 7.0.6.

More info: Why doesn't Magento 2.1 support PHP 7.0.3 to 7.0.5?

Solution: Update your PHP version.


The answer is that you have to completely uninstall php5 and components and then install php 7.0 using the process found here: https://askubuntu.com/questions/705880/how-to-install-php-7

then make sure to install the necessary modules and you will be back in business...if you check your phpinfo.php you will probably find that even though you have installed php7 it is not the default php being used and thus you are getting that error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.