1

I've already applied the patch MDVA-532.

When I run composer update magento/magento-composer-installer I got this error:

Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested package magento/product-community-edition == 2.0.6.0 could not be found.

Problem 2 - Installation request for braintree/braintree_php == 2.39.0.0 -> satisfiable by braintree/braintree_php[2.39.0]. - magento/product-community-edition 2.1.0 requires braintree/braintree_php 3.7.0 -> satisfiable by braintree/braintree_php[3.7.0]. - magento/product-community-edition 2.1.0 requires braintree/braintree_php 3.7.0 -> satisfiable by braintree/braintree_php[3.7.0]. - Conclusion: don't install braintree/braintree_php 3.7.0 - Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.0].

Potential causes:

Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.


When I run composer update I got this error:

Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for magento/data-migration-tool ~2.0.0 -> satisfiable by magento/data-migration-tool[2.0.5, 2.0.0, 2.0.2, 2.0.7]. - Conclusion: don't install magento/framework 100.1.0 - magento/product-community-edition 2.1.0 requires magento/framework 100.1.0 -> satisfiable by magento/framework[100.1.0]. - magento/product-community-edition 2.1.0 requires magento/framework 100.1.0 -> satisfiable by magento/framework[100.1.0]. - Conclusion: don't install magento/framework 100.1.0 - Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.0].

  • How did you install Magento 2 originally? Via github repo? – Raphael at Digital Pianism Jun 23 '16 at 18:04
  • I installed it via create composer create-project – Luis Garcia Jun 23 '16 at 18:07
2

I've bumped into the same issue. Any attempt to upgrade to version 2.1 bumped into various messages like "Conclusion: don't install magento/module-widget" or "Can only install one of". Closer inspection of all packages defined in my composer.json showed that it was calling for various modules of version 100.0.* while actually the upgrade messages mentioned that version 100.1.x was needed.

I changed all instances of 100.0.* to 100.* and this allowed me to upgrade.

Note that I assume that this versioning scheme follows the semantic versioning standards, meaning that this allows me to upgrade to newer minor versions without breaking backwards compatibility. Also note that I've run this on various development sites, where I'm just developing Magento 2 extensions. I don't have any Magento 2 project, so don't care much about the core. It might be that my composer.json hacks are not meant for production.

  • Did you try something like this: composer require magento/magento-composer-installer:100.1.0 followed by composer update? But if you already applied the patch I don't think you have to do that. – Steve Johnson Jun 24 '16 at 21:50
  • Yes, adding a composer require for every single package would work also. But that's the same as editing composer.json manually. There are about 20 packages that jumped from 100.0 to 100.1, so I modified composer.json directly. – Jisse Reitsma Jun 26 '16 at 5:53
1

This is not really an answer but this thread helped me to find my problem! I tried to upgrade Magento from 2.0.4 to 2.1.0 Applied the 532 patch. And followed the docs from http://devdocs.magento.com/guides/v2.0/release-notes/tech_bull_21-upgrade.html and http://devdocs.magento.com/guides/v2.0/comp-mgr/cli/cli-upgrade.html But was getting this problem:

- The requested package "magento/product-community-edition 2.1.0 exists" as magento/product-community-edition[2.0.4] but these are rejected by your constraint.

Only after I have found this topic, restored my composer.json and run

composer update magento/magento-composer-installer

And then 2 usuall update commands, it became working!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.