1

I am trying to upgrade Magento 2.3.4 to 2.3.5-p2 but i am facing a composer error regarding Google shopping.

First i upgraded from 2.3.4 to 2.3.5-p1 without any problems, but when trying to upgrade from 2.3.5-p1 to 2.3.5-p2 i am getting this error:

*Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for magento/product-community-edition 2.3.5-p2 -> satisfiable by magento/product-community-edition[2.3.5-p2].
  • magento/product-community-edition 2.3.5-p2 requires magento/google-shopping-ads 4.0.1 -> satisfiable by magento/google-shopping-ads[4.0.1] but these conflict with your requirements or minimum-stability.*

I have tried to set composer setting to:

composer config minimum-stability dev

composer config prefer-stable true

But that does not solve the issue. Any ideas?

2
  • Delete your whole vendor folder and execute composer update again.
    – Black
    Aug 31, 2020 at 10:30
  • 1
    Deleting vendor folder and running composer update again did not solve the issue either
    – Robert
    Sep 1, 2020 at 8:35

1 Answer 1

0

Something seems to be wrong with your composer.json. Compare it with a fresh one or replace it and then call composer update again.

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "config": {
        "preferred-install": "dist",
        "sort-packages": true
    },
    "require": {
        "magento/product-community-edition": "2.3.5-p2"
    },
    "require-dev": {
        "allure-framework/allure-phpunit": "~1.2.0",
        "dealerdirect/phpcodesniffer-composer-installer": "^0.5.0",
        "friendsofphp/php-cs-fixer": "~2.14.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento-coding-standard": "*",
        "magento/magento2-functional-testing-framework": "~2.6.4",
        "pdepend/pdepend": "2.5.2",
        "phpcompatibility/php-compatibility": "^9.3",
        "phpmd/phpmd": "@stable",
        "phpstan/phpstan": "^0.12.2",
        "phpunit/phpunit": "~6.5.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "~3.4.0"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/",
            "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": [
                "app/code/",
                "generated/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/",
            "Magento\\PhpStan\\": "dev/tests/static/framework/Magento/PhpStan/"
        }
    },
    "version": "2.3.5-p2",
    "minimum-stability": "stable",
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}
1
  • 2
    Thanks! I found out there was a old Google ads module still in the composer.json file called "magento/google-shopping-ads": "^3.0". Removing this running "composer remove magento/google-shopping-ads" solved the issue.
    – Robert
    Sep 2, 2020 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.