Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0
votes
0answers
26 views

Magento 2.4.0 upgrade to 2.4.3 error

I am getting error while upgrading Magento 2.4.0 CE to 2.4.3 while executing setup:upgrade command. Cannot instantiate interface Magento\MediaContentSynchronizationApi\Model\GetEntitiesInterface#0 /...
0
votes
3answers
33 views

Composer memory size fatal error

I keep getting this error every time i run anything related to composer (install, update, require, etc.) Ive tried almost every website or solution I could find to no avail. Can anyone tell me how to ...
0
votes
0answers
9 views

Magento 2 : Magento\Setup\Mvc\Bootstrap\InitParamListener containes 1 abstract method

I am facing issue when I execute command of upgrade & deploy. I executed composer update command. I know it's repeat question and tried solution But I didn't solve issue yet. Can anyone please ...
0
votes
3answers
37 views

How do I install the latest Magento 2 via composer with sample data and Elasticsearch?

Using Debian 10, I installed PHP 7.4, PHP-FPM 7.4, Mysql 8, NGINX, Elasticsearch, Magento2 via composer, Redis-Server, varnish, Changed the ownership of all files to a user, and run NGINX using this ...
0
votes
1answer
23 views

Magento 2.4, Error: Your requirements could not be resolved to an installable set of packages

I'm trying to install extinctions to Magento 2.4 and I have the following error: composer command: composer require mageplaza/module-core Updating dependencies Your requirements could not be ...
0
votes
0answers
8 views

Running composer require --update-with-dependecies second time updates some additional modules

I have an installer module that actually installs its child modules when we hit the composer require command. When I try to update the module to its latest using "composer require --update-with-...
0
votes
2answers
33 views

Failed to open stream: Permission denied on only one module

One of our extensions give the following error message on the front page: Warning: require_once(/var/www/html/magento2/app/code/xxxVendor/xxxModule/registration.php): failed to open stream: ...
0
votes
2answers
16 views

Can't install extension prisync/pricer over composer

Marketplace Magento doesn't let customer install by package download. They only let customer install extension over composer. But when I try to install extension composer require prisync/pricer. It ...
0
votes
0answers
21 views

How to install magento extensions

I'm new to Magento, and I would like to install a magento extension. When i follow the normal steps to install via Composer it gives me this error: what does it mean? Can you help me? Thanks in ...
0
votes
0answers
17 views

install Magento2 enterprise cloud extension on local

I have our Magento2.3.4 enterprise all downloaded onto my local mac. I do not have the site actually running on my mac just the files downloaded so I can git pull and push it up to the staging. My ...
0
votes
0answers
139 views

get magento to use Composer 2

I'm actually having this issue but first I want to resolve why it's still looking at Composer 1. me@server:/.../magentoproject$ sudo ./bin/magento sampledata:deploy [sudo] password for me: <warning&...
0
votes
2answers
132 views

Update Magento 2.3.0 to 2.4 Error in "Check Component Dependency"

I'm trying to update Magento from 2.3.0 to 2.4 using the setup Wizard. In the Readiness Check, I'm getting the following error: **Check Component Dependency We found conflicting component dependencies....
0
votes
1answer
59 views

Magento 2 : Getting Error while upgrade magento from 2.2.6 to latest version 2.4.3

I am try to upgrade magento version from 2.2.6 to 2.4.3 using composer method. When try to that, I face following error which attached in screenshot: https://i.imgur.com/wGoTAFn.png, please help..
0
votes
1answer
271 views

No lockfile found. Unable to read locked packages Magento2.4.3 composer update issue

/app/magento2# composer update Loading composer repositories with package information In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate Updating dependencies Nothing to modify in lock ...
0
votes
2answers
24 views

How to configure Magento 2 to have personal/private develpment extensions just for myself

I have several development tools which I personally use like: https://github.com/ho-nl/magento2-Ho_Templatehints https://github.com/mage2tv/magento-cache-clean Is it possible to somehow configure ...
0
votes
5answers
856 views

Magento 2.4.3 Installation Error

I am try to install Magento 2.4.3 with the command in Ubuntu. After follow all the steps, when I try to run the Magento from browser, it show me error like this : Composer detected issues in your ...
0
votes
1answer
56 views

Getting "Vendor autoload is not found." error even the composer install succeeded

When i open Magento in browser i got Autoload error Vendor autoload is not found. Please run 'composer install' under application root directory. even i have run composer update composer install on ...
0
votes
0answers
29 views

Magento 2: Failed to set PHP CodeSniffer installed_paths Config on upgrade to 2.4.3 from 2.3.0

I am getting this error after running: composer update command: Failed to set PHP CodeSniffer installed_paths Config I tried composer global require "squizlabs/php_codesniffer=*" but still ...
1
vote
3answers
631 views

Magento 2.4.3 and Composer error messages for allure phpunit and ramsey uuid - Can't continue with update

I'm getting some error messages from composer, when I try to upgrade from Magento 2.4.2 to Magento 2.4.3, and these are: - Root composer.json requires magento/product-community-edition 2.4.3 -> ...
1
vote
1answer
156 views

Multiple users keys for the same repository

Hey guys I'm building a Magento 2 app where there are 2 different teams working on the project. 1 internally and the other outside of our premises and we have 2 separate Magento marketplace accounts. ...
0
votes
2answers
415 views

Laminas compile error at update to 2.4.3

I was updating Magento Community from 2.4.2 to 2.4.3 and get this error at compile on 55%: Deprecated Functionality: Class Laminas\Hydrator\Reflection is deprecated, please use Laminas\Hydrator\...
0
votes
3answers
3k views

Upgrade to magento 2.4.3

I'm trying to upgrade Magento 2.4.2 to the latest release of Magento 2.4.3 How can I do this with the composer?
0
votes
1answer
51 views

Unable to uninstall Magento 2 Luma Theme - "frontend/Magento/luma is not an installed Composer package"

I am running a Magento 2.3.6 system and I built my own theme which inherits from Magento/blank. Since I don't need the Luma theme, I want to properly get rid of it. I followed the instructions from ...
0
votes
1answer
129 views

How could I check outdated extensions installed via Composer?

I have 30 extensions installed via Composer but when I need to check all the outdated extensions running the command below a huge list of non-extensions shows up, containing all the dependencies and ...
0
votes
2answers
530 views

M2.4 Exception throwing while executing composer require: Higher matching version 2.3.x of xxx/module-xxxx was found in public repository packagist

While executing composer require xxxx/module-xxxx I'm facing below error on the console. Repository is private at the moment. [Exception] ...
0
votes
0answers
18 views

Items are missing on Order Details Page

I am getting an error, when customers are placing an order then on In admin Sales=> Order details page Orders items are missing. But invoice is created successfully. All items are coming in when I ...
0
votes
1answer
21 views

magento cli error after module installation by composer

i use magetno 2.2.3 . the bin/magento cli is working fine until I add a module by composer require [module name] --ignore-platform-reqs.after that it gives me a long term error : so how should I ...
0
votes
2answers
401 views

Magento 2.4.3 - Module and Theme Installation not working

I have installed Magento 2.4.3 via composer and trying to install custom frontend/admin theme and custom modules. These modules are already working in version 2.3 that have been copied and added at ...
0
votes
1answer
42 views

enabling module error in vendor after installing with composer by CLI

I add a module with composer and then try to enable it by writing the command php bin/magento module:enable SR_UnicodeUrl but I get a long error in response that starts with this phrase Unknown ...
0
votes
0answers
50 views

Magento 2: Installing patch with Composer - package "not locked"

An established Magento extension company sent me a patch to install as there was an issue with our local installation. I tried installing it with Composer but it didn’t seem to change the code in the ...
1
vote
0answers
23 views

Unable to import the sample data

php -dmemory_limit=5G bin/magento sampledata:deploy used this command but return the error Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 4096 bytes) in F:\xampp\...
0
votes
0answers
14 views

Inform users of an extension of a major update via composer?

Lets say, I have coded an extension, that is hosted on github. You can install it via composer and composer adds a new require(ment) to the main composer.json. For example: "require": { ...
0
votes
1answer
168 views

Magento2 - Getting error Could not find a matching version of package After submitting in packagist.org

I have Created New Module and uploaded in github. Module Name : vrajeshpatel4u/helloworld Url : https://github.com/vrajeshpatel4u/helloworld/ Packagist Url : https://packagist.org/packages/...
0
votes
2answers
484 views

CLI Error when updating Composer because it requires a Plugin API version ("1.0") that does not match your Composer installation ("2.1.0")

I'm trying to update composer and dependencies but getting this CLI error: The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version (&...
0
votes
1answer
244 views

Upgrade Magento from 2.2.4 to 2.3.7

I'm trying to upgrade Magento from 2.2.4 to 2.3.7 I got a lot of errors, so i fixed them by changing module's version, now composer require magento/product-community-edition=2.3.7 --no-update ...
0
votes
0answers
179 views

Composer\Downloader\TransportException (HTTP/1.1 404 Not Found)

I'm trying to run composer update but it keeps throwing the following error: [Composer\Downloader\TransportException] The "https://packagist.org/p/symfony/polyfill-php72%...
0
votes
4answers
122 views

Not able to install Google Pay module(unboundcommerce/module-googlepay)

As per the requirement I need to integrate Google Pay in my Magento 2 site. But I am getting an error added below. Command php -dmemory_limit=6G vendor/bin/composer require unboundcommerce/module-...
0
votes
1answer
60 views

Composer Installing AWS SDK On Magento 2.3

I'm trying to download composer require aws/aws-sdk-php but getting this error: I don't know the issue, if anyone knows about this please help me out. composer.json { "name": "...
0
votes
0answers
279 views

Problem when install any thing using composer in Magento 2.4.1

Am trying to install any module using composer v.1 and v.2 but I get this error all the time Problem 1 - The requested package laminas/laminas-servicemanager (locked at 2.7.11, required as ^3.6) ...
2
votes
1answer
801 views

Cannot upgrade Magento from 2.4.2 to 2.4.2-p1 using Composer 2

I have upgraded Magento community edition from version 2.4.1 to 2.4.2 using Composer version 1. Magento 2.4.2 supports Composer 2 (see https://devdocs.magento.com/guides/v2.4/release-notes/open-source-...
0
votes
0answers
69 views

Apply composer patch from a required composer module

I wonder how and if it is possible to apply a patch or if there's any other solution to modify the magento/framework from a required composer package. Patch successfully applied. The following patch ...
0
votes
2answers
41 views

Magento 2 EE: Running composer update is giving error

I am trying to run composer update and want to push the changes to magento cloud but is giving the following error: Problem 1 magento/product-enterprise-edition 2.3.4 requires ext-bcmath * -> the ...
0
votes
0answers
28 views

How to ignore/exclude specific folder from di:compile?

I have a file in my plugin folder which I don't want to be compiled while running bin/magento setup:di:compile . Is there any way to do that?
0
votes
2answers
45 views

Problem when download dompdf in magento 2.4.1

Hi am trying to install dompdf in Magento 2.4.1 using composer v1 but no success
0
votes
1answer
52 views

Unable to install theme with composer

I'm trying to install Alpaca theme following the documentation. I've created my composer.json file under app/design/frontend/ben/gotheme/composer.json { "name": "ben/gotheme", &...
0
votes
0answers
53 views

Magento 2 : Custom extension install and update composer require using public and private key

I have created the custom extension for my client and the client want to install and update the custom extension like Amasty and Aheadworks. So can anyone give any reference URL and how can I do the ...
0
votes
1answer
204 views

"Constant name is expected" when installing a module

I'm trying to install a third party module via composer with very low support, so I have to debug it myself. The problem I'm encountering an error "Constant name is expected" when I try to ...
1
vote
2answers
164 views

Can't install new composer modules due to PHP version

I'm trying to install a module on Github through composer require postcode-nl/api-magento2-module However, the installation is failing with this error: Updating dependencies (including require-dev) ...
0
votes
1answer
58 views

Magento 2 - How to install extension from marketplace.magento.com via composer?

I bought a this extension from marketplace.magento.com. I tried to install it via composer like this: composer require bsscommerce/customer-approval But I get [InvalidArgumentException] Could not ...
0
votes
2answers
35 views

Magento 2: So I have upgraded my magento from 2.3.6 to 2.4

So, I am trying to upgrade my magento from 2.3.6 to 2.4. I have updated my PHP from 7.3 to 7.4 for that. I am able to run composer install, composer update and all other magento commands without any ...

1
2 3 4 5
13