0

Magento 2.4.3-p1

I am trying to install an extension using this command:

composer require dhl/shipping-m2

I am getting this conflict:

Problem 1
    - symfony/deprecation-contracts v3.0.0 requires php >=8.0.2 ->
your PHP version (7.4.28) does not satisfy that requirement.
    - symfony/deprecation-contracts v3.0.0 requires php >=8.0.2 ->
your PHP version (7.4.28) does not satisfy that requirement.
    - symfony/deprecation-contracts v3.0.0 requires php >=8.0.2 ->
your PHP version (7.4.28) does not satisfy that requirement.
    - Installation request for symfony/deprecation-contracts (locked
at v3.0.0) -> satisfiable by symfony/deprecation-contracts[v3.0.0].

When I run composer with PHP 8 , I am getting:

Problem 1
    - amzn/amazon-payments-magento-2-plugin 5.9.1 requires php
~7.0.13||~7.1.0||~7.2.0||~7.3.0||~7.4.0 -> your PHP version (8.0.14)
does not satisfy that requirement.
    - amzn/amazon-payments-magento-2-plugin 5.9.1 requires php
~7.0.13||~7.1.0||~7.2.0||~7.3.0||~7.4.0 -> your PHP version (8.0.14)
does not satisfy that requirement.
    - amzn/amazon-payments-magento-2-plugin 5.9.1 requires php
~7.0.13||~7.1.0||~7.2.0||~7.3.0||~7.4.0 -> your PHP version (8.0.14)
does not satisfy that requirement.
    - Installation request for amzn/amazon-payments-magento-2-plugin
5.9.1 -> satisfiable by amzn/amazon-payments-magento-2-plugin[5.9.1]

How would I resolve this? The PHP version I want to use is 7.4.

Thanks!

1 Answer 1

1

Solved it myself by adding the --ignore-platform-reqs to my command!

composer require dhl/shipping-m2 --ignore-platform-reqs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.