I currently have Magento running on Ubuntu Xampp, and attempted to run composer on a theme file, which prompted me to install a load of PHP extensions. I did this (7.2 for all of them, same as system version) which fixed those errors, but then it suddenly came up with
magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.15) does not satisfy that requirement.
This is in response to
composer install in the relevant theme folder.
However, the Magento admin panel clearly states that I'm on version 2.3.1 which does support PHP 7.2.11 (which is earlier than 7.2.15, but surely this shouldn't be a breaking change). I installed Magento through the bitnami addon installer to Xampp, which could be the cause as it somehow installed an older version? (Although again, admin panel states I'm running 2.3.1). Could this be something to do with the version the theme in specific is looking for?
Any advice would be very appreciated. Thanks!