0

I am trying to update one of my payment gateway extension through composer and the command is

composer update razorpay/update

But I am getting the below errors

Problem 1 - guzzlehttp/guzzle 7.2.0 requires php ^7.2.5 || ^8.0 -> your PHP version (7.1.33) does not satisfy that requirement. - guzzlehttp/guzzle 7.1.1 requires php ^7.2.5 -> your PHP version (7.1.33) does not satisfy that requirement. - guzzlehttp/guzzle 7.1.0 requires php ^7.2.5 -> your PHP version (7.1.33) does not satisfy that requirement. - guzzlehttp/guzzle 7.0.1 requires php ^7.2.5 -> your PHP version (7.1.33) does not satisfy that requirement. - guzzlehttp/guzzle 7.0.0 requires php ^7.2.5 -> your PHP version (7.1.33) does not satisfy that requirement. - Conclusion: don't install facebook/php-business-sdk 9.0.3 - Conclusion: don't install facebook/php-business-sdk 9.0.2 - Conclusion: don't install facebook/php-business-sdk 9.0.1 - Conclusion: remove guzzlehttp/guzzle 6.4.1 - Installation request for facebook/php-business-sdk ^9.0 -> satisfiable by facebook/php-business-sdk[9.0.0, 9.0.1, 9.0.2, 9.0.3]. - Conclusion: don't install guzzlehttp/guzzle 6.4.1 - facebook/php-business-sdk 9.0.0 requires guzzlehttp/guzzle ^6.5 || ^7.0 -> satisfiable by guzzlehttp/guzzle[6.5.0, 6.5.1, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 7.0.0, 7.0.1, 7.1.0, 7.1.1, 7.2.0]. - Can only install one of: guzzlehttp/guzzle[6.5.0, 6.4.1]. - Can only install one of: guzzlehttp/guzzle[6.5.1, 6.4.1]. - Can only install one of: guzzlehttp/guzzle[6.5.2, 6.4.1]. - Can only install one of: guzzlehttp/guzzle[6.5.3, 6.4.1]. - Can only install one of: guzzlehttp/guzzle[6.5.4, 6.4.1]. - Can only install one of: guzzlehttp/guzzle[6.5.5, 6.4.1]. - Installation request for guzzlehttp/guzzle (locked at 6.4.1) -> satisfiable by guzzlehttp/guzzle[6.4.1]

Previously I am trying to install the Facebook Pixel extension due to some technical issues we didn't install. After that when I am trying to install or update the extension I am getting the above error.

For reference please find the attached image. enter image description here

2 Answers 2

0

Have the same problem with my Magento 2.3.1 with PHP version 7.2.17

- facebook/php-business-sdk 11.0.0 requires guzzlehttp/guzzle ^6.5 || ^7.0

Tried lower version of SDK as per your Facebook_Business extension version or require.

I tried with lower SDK version 8.0.0 and its working fine in my case.

composer require facebook/php-business-sdk 8.0.0
0

Hi you are installing guzzlehttp/guzzle 7.2.0 version which requires php version ^7.2.5 || ^8.0 and your PHP version is (7.1.33).

So, upgrade your php version to 7.3 or 7.2.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.