0

When upgrading Magento 2.2 to 2.3, I am using php 7.1

However, during the readiness check, I am getting these errors:

magento/module-sales 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.26) does not satisfy that requirement.

If it requires atleast 7.1, how come its telling me it now requires php 7.0 for some modules??

1

This must be an issue with your third party extension. So the best thing is to look for that third party extension's composer.json file and find required php version, if your current php version is not available in "require" then please add it.

refer like below:

"require": {
        "php": "~5.6.0|7.0.2|7.0.4|~7.0.6|~7.1.26"
    },
  • its not a third party because the module is magento/module-sales....i tried adding your line into the composer.json file of vendor/magento/module-sales but I am still getting the same error – styzzz Jan 26 at 23:16
  • I mean you might have a third party extension that uses or has dependencies on module-sales that would probably include it on its composer json require. – fmsthird Jan 26 at 23:18
  • 2
    You probably have a 3rd party module that requires module-sales in 100.* version. Magento 2.3 sets module-sales at 102.0.0. So check in composer.lock for module-sales and see which other package requires it in 100.* version. Then update that package or remove it if there is no working version for Magento 2.3 – Zefiryn Jan 27 at 0:28
  • You are correct. A third party module was interfering with the upgrade. I uninstalled the module and that fixed that problem. Now I have another problem. Magento upgrades suck! – styzzz Jan 27 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.