0

I am trying to upgrade my magento 2.2.6 to 2.3.2 for this i had followed all the steps mentioned in https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html

when i run composer update command i am getting following command

Problem 1
    - Conclusion: don't install magento/framework 101.0.9
    - Conclusion: don't install magento/framework 101.0.8
    - Conclusion: don't install magento/framework 101.0.7
    - Conclusion: remove magento/framework 101.0.6
    - Conclusion: don't install magento/framework 101.0.6
    - Conclusion: don't install magento/framework 101.0.5
    - Conclusion: don't install magento/framework 101.0.4
    - Conclusion: don't install magento/framework 101.0.3
    - Conclusion: don't install magento/framework 101.0.2
    - Conclusion: don't install magento/framework 101.0.1
    - Conclusion: don't install magento/framework 101.0.0
    - Conclusion: don't install magento/framework 101.0.4
    - Conclusion: don't install magento/framework 101.0.3
    - Conclusion: don't install magento/framework 101.0.2
    - Conclusion: remove magento/data-migration-tool 2.2.5
    - Conclusion: don't install magento/framework 101.0.9
    - Conclusion: don't install magento/data-migration-tool 2.2.5
    - Conclusion: don't install magento/framework 101.0.8
    - Conclusion: don't install magento/framework 101.0.7
    - Conclusion: don't install magento/framework 101.0.6
    - Conclusion: don't install magento/product-community-edition 2.3.2
    - magento/framework 101.0.0 requires colinmollenhour/php-redis-session-abstract ~1.2.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2.2].
    - colinmollenhour/php-redis-session-abstract v1.2.2 requires colinmollenhour/credis 1.6 -> satisfiable by colinmollenhour/credis[1.6].
    - Can only install one of: colinmollenhour/credis[1.6, 1.10.0].
    - magento/product-community-edition 2.3.2 requires colinmollenhour/credis 1.10.0 -> satisfiable by colinmollenhour/credis[1.10.0].
    - Installation request for magento/data-migration-tool 2.2.5 -> satisfiable by magento/data-migration-tool[2.2.5].
    - Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2].
    - magento/product-community-edition 2.3.2 requires magento/framework 102.0.2 -> satisfiable by magento/framework[102.0.2].
    - Can only install one of: magento/framework[101.0.1, 102.0.2].
    - Can only install one of: magento/framework[102.0.2, 101.0.1].
    - magento/data-migration-tool 2.2.5 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.6, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.7, 101.0.8, 101.0.9].
    - Conclusion: don't install magento/framework 101.0.5
0

you can try to upgrade with automatic preconfigured script.

https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/upgrade-with-script.html

https://raw.githubusercontent.com/magento/magento2/2.3/dev/tools/UpgradeScripts/pre_composer_update_2.3.php

php -f pre_composer_update_2.3.php -- --root='path/to/magento/' --repo=https://repo.magento.com/

Upgrading your Magento installation with our script, which makes the upgrade process semi-automated, is the preferred method.

Use the manual process if you previously made updates to the same values that the upgrade script affects, because the script will override those values.

The upgrade script:

  1. Updates Magento with the 2.3 requirements.
  2. Backs up the composer.json file.
  3. Specifies the new version of the Magento metapackage.
  4. Updates the "require-dev" section in the composer.json file.
  5. Adds "Zend\Mvc\Controller\": "setup/src/Zend/Mvc/Controller/" to the "autoload":"psr-4" section in the composer.json file.
  6. Backs up and updates the magento/updater, if it has been installed.
  7. Updates the "name", "version", and "description" fields in the composer.json file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.