0

upgrade Magento 2.3.2 to 2.3.3 give zendframework/zend-stdlib error.

Your requirements could not be resolved to an installable set of packages. Problem 1 - magento/product-community-edition 2.3.3 requires zendframework/zend-stdlib ^3.2.1 -> satisfiable by zendframework/zend-stdlib[3.2.1, 3.3.x-dev, 3.2.x-dev] but these conflict with your requirements or minimum-stability. - magento/product-community-edition 2.3.3 requires zendframework/zend-stdlib ^3.2.1 -> satisfiable by zendframework/zend-stdlib[3.2.1, 3.3.x-dev, 3.2.x-dev] but these conflict with your requirements or minimum-stability. - Installation request for magento/product-community-edition 2.3.3 -> satisfiable by magento/product-community-edition[2.3.3]. Installation failed, reverting ./composer.json to its original content.

composer require zendframework/zend-stdlib ^3.2.1

Your requirements could not be resolved to an installable set of packages.

Problem 1 - magento/framework 102.0.2 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability. - magento/framework 102.0.2 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability. - magento/framework 102.0.2 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability. - magento/framework 102.0.2 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7, 2.7.x-dev] but these conflict with your requirements or minimum-stability. - Installation request for magento/framework 102.0.2 -> satisfiable by magento/framework[102.0.2].

Installation failed, reverting ./composer.json to its original content.

PHP version: 7.2.20

1

This message looks like one additional component depends on magento/framework 102.0.2 as the newest version, which is from Magento 2.3.2. But I suppose the error message is still not complete?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.