0

Running the different commands below and getting errors with each of them. How do I get the data migration tool to install?

I also pasted in our composer.json file below.

First Attempt

This one says data-migration-tool 2.2.0 requires magento/framework ~101.0.0. But It doesn't want to install with my version of php.

composer require magento/data-migration-tool:2.2.0
----
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.18) overridden by "config.platform.php" version (7.2.18) does not satisfy that requirement.
- magento/data-migration-tool 2.2.0 requires magento/framework ~101.0.0 -> satisfiable by magento/framework[101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.4, 101.0.5, 101.0.6, 101.0.7, 101.0.8, 101.0.9].
- Installation request for magento/data-migration-tool 2.2.0 -> satisfiable by magento/data-migration-tool[2.2.0].

Installation failed, reverting ./composer.json to its original content.

Second Attempt

This one says don't install magento/framework ~101.0.0 but then to install it?

composer require magento/data-migration-tool:2.2.0 --ignore-platform-reqs
----
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/framework (locked at 102.0.1) -> satisfiable by magento/framework[102.0.1].
- Installation request for magento/data-migration-tool 2.2.0 -> satisfiable by magento/data-migration-tool[2.2.0].
- Conclusion: don't install magento/framework 101.0.0
- Can only install one of: colinmollenhour/php-redis-session-abstract[v1.4.1, v1.3.4].
- Can only install one of: colinmollenhour/php-redis-session-abstract[v1.3.4, v1.4.1].
- Can only install one of: colinmollenhour/php-redis-session-abstract[v1.3.4, v1.4.1].
- Conclusion: install magento/framework 101.0.0|install colinmollenhour/php-redis-session-abstract v1.3.4
- Installation request for colinmollenhour/php-redis-session-abstract (locked at v1.4.1) -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.4.1].

Installation failed, reverting ./composer.json to its original content.

More Info

The composer update command seems to work fine and it updates everything. Only issues with that is that it tells me phpunit/phpunit-mock-objects is abandoned.

composer update
----
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files

composer.json

{
    "name": "magento/project-enterprise-edition",
    "description": "eCommerce Platform for Growth (Enterprise Edition)",
    "type": "project",
    "license": [
        "proprietary"
    ],
    "config": {
        "preferred-install": "dist",
        "platform": {
            "php": "7.2.18"
        }
    },
    "require": {
        "algolia/algoliasearch-magento-2": "^1.11",
        "ethanyehuda/magento2-cronjobmanager": "^1.8",
        "magento/product-enterprise-edition": "2.3.1"
    },
    "require-dev": {
        "friendsofphp/php-cs-fixer": "~2.13.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento2-functional-testing-framework": "~2.3.13",
        "pdepend/pdepend": "2.5.2",
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.5.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "3.3.1",
        "allure-framework/allure-phpunit": "~1.2.0"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/",
            "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": [
                "app/code/",
                "generated/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "version": "2.3.1",
    "minimum-stability": "stable",
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}
0

Missed the rule about version number matching your magento version number.

https://devdocs.magento.com/guides/v2.3/migration/migration-tool-install.html Version number must match

composer require magento/data-migration-tool:2.3.1
----
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing magento/data-migration-tool (2.3.1): Downloading (100%)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No 
replacement was suggested.
Writing lock file
Generating autoload files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.