0

I am using LAMP on which I have PHP 7.2 I install Ampps on which I have PHP 7.1 How I have to run composer update command? If I run it gave me PHP version error (definitely it will give 2.2.7 don't require php7.2) How I have to run composer using Ampps's PHP version instead of base PHP version.

0

I figure it out. You have to run update composer like the following.

/usr/local/ampps/php-7.1/bin/php /usr/local/bin/composer update

you have to give path of your required php (the version using on Ampps or Xampp) in first argument like /usr/local/ampps/php-7.1/bin/php and in second argument gave composer path like /usr/local/bin/composer then add update at the end.

  • 1
    I do not recommend executing composer with sudo – Philipp Sander Jan 21 at 12:25
  • I had updated now try and share your view for answer. I had updated my my packages successfully using above. - Installing illuminate/encryption (v5.5.44): Downloading (100%) – Hassan Ali Shahzad Jan 21 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.