1

on base ubuntu Iusing php5.6 on xampp using php7 for M2 when run command

php bin/magento setup:upgrade

giving error:

Magento supports 7.0.2, 7.0.4, and 7.0.6 or later. Please read http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements.html

How to point to xampp php

2

you need to point xampp php by following command it will work:

/opt/lampp/bin/php bin/magento setup:upgrade

or add sudo if you are not root user, becaus its need to generate and delete some files

sudo /opt/lampp/bin/php bin/magento setup:upgrade
0
sudo /opt/lampp/bin/php bin/magento setup:upgrade

Make sure you run the above command in root directory in ubuntu your magento root directory.

before above run this command :

cd /opt/lampp/htdocs/your_mangento_root_folder
  • what is difference in actual answer & in yours ? – Hassan Ali Shahzad Sep 21 '19 at 7:28
  • The new users get confused where the command should run the only thing i have mentioned is ..."Make sure you run the above command in root directory". I am new to it once i get the your command i read it somewhere else so i feel it could be helpful to new users like me.. – Homesh Paul Sep 22 '19 at 8:06
  • @HassanAliShahzad given you one upvote enjoy.. :) – Homesh Paul Sep 22 '19 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.