I'm trying to update Magento from 2.3.0 to 2.4 using the setup Wizard.
In the Readiness Check, I'm getting the following error:
**Check Component Dependency We found conflicting component dependencies.
Command "require" failed: Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
In InitCommand.php line 697:
Package magento/product-community-edition at version 2.4.3 has a PHP requir ement incompatible with your PHP version (7.2.34)
require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [...]**
I can't find out how to fix this error. I have tried changing the php from 7.2 to 7.3 or 7.4 but when I do, I get more errors in the Readiness Check.
Also, I tried using the composer self-update I get the folowing warning:
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option. The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
I'm using: Magento v2.30 PHP v7.2 Composer v2.1.6
Any idea what the problem is and how I can fix it? Thank you in advance.