0

Included in Magento documentation the following steps to install Google recaptcha:2.0.0 on Magento Open Source 2.2.6:

Install Module:

 composer require msp/recaptcha:2.0.0

Enable Module:

php bin/magento module:enable --all

php bin/magento setup:upgrade

For the first code composer require msp/recaptcha:2.0.0, I get this error message:

 Problem 1
    - The requested package magento/product-community-edition (locked at 2.2.5, required as 2.2.6) is satisfiable by magento/product-community-edition[2.2.5] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Conclusion: remove magento/product-community-edition 2.2.6
    - Conclusion: don't install dotmailer/dotmailer-magento2-extension 2.5.0
    - Installation request for magento/product-community-edition 2.2.6 -> satisfiable by magento/product-community-edition[2.2.6].
    - Conclusion: don't install dotmailer/dotmailer-magento2-extension 2.5.0
    - magento/product-community-edition 2.2.6 requires dotmailer/dotmailer-magento2-extension 2.6.0 -> satisfiable by dotmailer/dotmailer-magento2-extension[2.6.0].
    - Can only install one of: dotmailer/dotmailer-magento2-extension[2.5.0, 2.6.0].
    - Can only install one of: dotmailer/dotmailer-magento2-extension[2.5.0, 2.6.0].
    - Installation request for dotmailer/dotmailer-magento2-extension (locked at 2.5.0) -> satisfiable by dotmailer/dotmailer-magento2-extension[2.5.0].

Any suggestions please about this problem?

0

Try to not add the 2.0.0, use without the version

composer require msp/recaptcha

because that module is already upgraded

https://packagist.org/packages/msp/recaptcha is connected with this https://github.com/magento/magespecialist_ReCaptcha/releases . I think the 2.0.2 will be Upgraded .

composer require msp/recaptcha:2.0.2

Than check again if the error shows

  • I've try it without version but the same problem appear. – mahmoudismail Dec 28 '18 at 11:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.