I am currently trying to update two MSP exensions in my version of Magento 2.3.2. But whenever I run the readiness check I get the following error:

Check Component Dependency We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2]. - magento/product-community-edition 2.3.2 requires msp/twofactorauth 3.1.1 -> satisfiable by msp/twofactorauth[3.1.1] but these conflict with your requirements or minimum-stability.

enter image description here

I've tried the solutions in the help documents but none of them seem to work.

The composer file seems to have the correct requirements:

"require": {
    "magento/product-community-edition": "2.3.2",
    "composer/composer": "@alpha",
    "mageplaza/module-gdpr": "^1.2",
    "msp/twofactorauth": "3.1.1",
    "msp/recaptcha": "2.1.2",
    "xtento/customtrackers": "2.1.7",
    "zendframework/zend-mime": "^2.7",
    "geoip2/geoip2": "^2.9",
    "livechat/module-magento-livechat": "2.3.0"
"require-dev": {
    "allure-framework/allure-phpunit": "~1.2.0",
    "friendsofphp/php-cs-fixer": "~2.13.0",
    "lusitanian/oauth": "~0.8.10",
    "magento/magento-coding-standard": "~1.0.0",
    "magento/magento2-functional-testing-framework": "~2.3.14",
    "pdepend/pdepend": "2.5.2",
    "phpmd/phpmd": "@stable",
    "phpunit/phpunit": "~6.5.0",
    "sebastian/phpcpd": "~3.0.0",
    "squizlabs/php_codesniffer": "3.3.1"

I've run the usual commands as follows but these have not resolved the issue:

composer update
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

Can anyone suggest what might be causing the issue.

1 Answer 1


OK. I've come up with a basic solution. Not ideal but here goes:

Essentially I removed twofactorauth and recaptcha from composer.json then updated the magento 2 system to the next version (2.3.4). Once this was complete I used:

composer require

To put the latest versions of the extensions back. The site now seems to be working properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.