1

Decided to check out Magento, so I downloaded the sample data and Magento CE. I installed the sample data and CE locally using WAMP.

Everything went smoothly, but when I go to view the frontend, it seems the main images are missing(see below). Also any links I click on, I get a Not Found message:

Not Found Error looks like this :

The requested URL /magento/accessories/eyewear.html was not found on this server.

Anyone else have a similar problem in the past? I'm perplexed as to how to correct this?

I tried reinstalling but got same result.

Thank you for your time. George

enter image description here

4

About Image Problem

Most probably, you may forget to merge the folders that is available in sample data (media, skin) folder with Magento's default media, skin folder. If you didn't do that, please merge those folders.

If you did that step, then you need to check the permission of media folder. You need to have both read & write (777) permission for this folder. Set that permission to media folder.

About Page Not Found Problem

Most probably, it is modRewrite issue. First you need to check whether this url works for you

 /magento/index.php/accessories/eyewear.html

Please note the insertion of index.php inside the url. If the above url actually "finds" the page, then it is surely a modeRewrite issue. You can fix it using following steps.

step 1: Go to to your site root folder and you can find the .htaccess file there. Open it with a text editor and find the line

#RewriteBase /magento/. 

Just replace it with

RewriteBase /

step 2: Then go to your admin panel and enable the Rewrites(set yes for Use Web Server Rewrites). You can find it at

System->Configuration->Web->Search Engine Optimization.

step 3: Remove all cache of your site. For this, remove all content that comes inside var/cache folder. Don't worry about this step.It is safe. This is where magento cache files are hold.

For more details, go through this post.

  • Happy to help you. If my answer helped you to resolve your problem, then feel free to accept it. – Rajeev K Tomy Dec 15 '14 at 2:29
  • Still having issue with the Page Not Found. Still working through it – George Dec 15 '14 at 2:46
  • you tried url that I have described ? – Rajeev K Tomy Dec 15 '14 at 2:47
  • Yes. That url worked. Went into .htaccess and made the change you suggested. Rewrites were already enabled. Deleted contents inside of var/cache. PNF still persist. – George Dec 15 '14 at 2:55
  • made changes in admin section. ie System->Configuration->Web->Search Engine Optimization. also do a cache refresh through system > cache management – Rajeev K Tomy Dec 15 '14 at 2:57
0

It worked for me after I added the following file to the /etc/httpd/conf.d directory:

magento.conf

Alias /mage /var/www/html/magento

<Directory /var/www/html/magento>

    Options FollowSymLinks

    AllowOverride all

     RewriteEngine On

 </Directory>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.