0

I followed the steps here to install a fresh magento - Installing Magento With The Full Download: http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/installing_magento_via_shell_ssh

I created an empty database, then went to the web interface (http://www.mydomain.com/magentoroot/) for the initial setup.

During the setup process, after I input the database information, the next page always gave me an error like the following:

a:5:{i:0;s:221:"Error in file: "***/app/code/core/Mage/Catalog/sql/catalog_setup/install-1.6.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'catalog_product_entity' already exists";i:1;s:1036:"#0 ***/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 ***/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.6.0.0.8')
#2 ***/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.6.0.0.8')
#3 ***/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 ***/app/code/core/Mage/Core/Model/App.php(412): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 ***/app/code/core/Mage/Core/Model/App.php(338): Mage_Core_Model_App->_initModules()
#6 ***/app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 ***/index.php(80): Mage::run('', 'store')
#8 {main}";s:3:"url";s:36:"/index.php/install/wizard/installDb/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

If I imported the sample data before going to the web interface for the initial setup, there would be no error.

But I don't want the sample data, I just want a clean Magento. Below is some more information:

  • Trying to install 1.9.1 and 1.9.0.1
  • This is a dedicated server. I created a clean development account---neither Magento nor anything else installed there before.
  • Run on PHP 5.5 and MySQL 5.5
  • CGI/FastCGI
1

Can check your database? It seems that there already are tables which Magento tries to create. Make sure that your browser doesn't timeout during database installation: if so then it will be terminated and on retry, there will be already partly installed data which will cause the error you posted (or similar).

If that is the issue, turn it off. In Firefox you should put 0 in the config field mentioned in post I linked to. Personally, I didn't run into such an issue with other browsers.

Anyway, clean your database first: remove all the tables created or just create new database and try to install. If the process will hang and you'll have this error again, then check if your browser's timeout setting is not an issue.

EDIT: After information about 500 internal server errors you prvoded in the comment, it may be FastCGI issue, like the one here.

|improve this answer|||||
  • Database was clean since I created it right before installing magento. And I did use Firefox. That gave me some hope now. I'll try your suggestion. Thank you! – Shawn Dec 20 '14 at 19:53
  • @Shawn Then it might be browser issue. It would explain why the tables turn out to be already created when installing on clean one. The process must have been terminated and ran again which may be beacuse of your web browser's timeout. – talonkingvskg Dec 20 '14 at 19:58
  • I'll just try on Chrome, then. You said other browsers had no such issue, right? – Shawn Dec 20 '14 at 19:59
  • At least in Chromium I had no such issue. In Firefox: only with few versions. Windows one (don't remember the number), and recently with Firefox 31.3.0. – talonkingvskg Dec 20 '14 at 20:03
  • I tried on Chrome but still had the error.... =( Any idea? – Shawn Dec 21 '14 at 0:59
1

The error message "SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'catalog_product_entity' already exists" means your database already has some Magento tables in it.

Are you sure you cleared the database completely before trying without sample data?

|improve this answer|||||
  • Yes. I created the database right before going to the web interface. – Shawn Dec 20 '14 at 19:51
0

Check local.xml file in your installation directory. It can be found in app->etc Here we declare the database name which is to be used for Magento. Check this if it contain the same name. Else try truncating all the data from DB and install from starting.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.