enter image description here recently i was upgrade magento 2.4.3 to 2.4.6-p6 for upgrade

i fired below cmd

composer require magento/product-community-edition 2.4.6-p5 --no-update

composer update --ignore-platform-reqs

after install latest version when i run setup:upgrade it will throw error

There is an error in /chroot/home/a77eba9d/28a6e11fee.nxcli.io/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php at line: 50 Cannot instantiate interface Magento\Theme\Model\Theme\StoreThemesResolverInterface#0 /chroot/home/a77eba9d/28a6e11fee.nxcli.io/vendor/magento/framework/ObjectManager/ObjectManager.php(70): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\Theme\M...') #1 /chroot/home/a77eba9d/28a6e11fee.nxcli.io/vendor/magento/module-theme/Model/Config/Customization.php(75): Magento\Framework\ObjectManager\ObjectManager->get('Magento\Theme\M...') #2 /chroot/home/a77eba9d/28a6e11fee.nxcli.io/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(121): Magento\Theme\Model\Config\Customization->__construct(Object(Magento\Store\Model\StoreManager), Object(Magento\Theme\Model\View\Design\Proxy), Object(Magento\Theme\Model\Theme\ThemeProvider), NULL)

i went to upgrade my magento version 2.4.3-p2 to 2.4.6-p5

  • After big code changes, such as application upgrade, try deleting the content of /generated and /var/cache folders, and then try again bin/magento set:up Commented Apr 18 at 14:44

3 Answers 3


If you are using Redis, flush the Redis cache by using the command redis-cli flushall

If the issue persists, remove the cache directories:

rm -rf var/cache/*
rm -rf var/page_cache/*
  • Thank you for your ans. but I don't use Redis. I've tried deleting the 'var/' and 'generated/' directories using 'rm -rf'. Commented Apr 17 at 16:50
  • Did you run bin/magento setup:upgrade after that? Does the issue persist?
    – Tu Van
    Commented Apr 17 at 17:12
  • After running the setup:upgrade command, it isn't functioning properly. Commented Apr 18 at 13:49
  • Can you please provide more information about this? Does the original issue persist? Or have you encountered a new issue?
    – Tu Van
    Commented Apr 18 at 14:40
  1. First you have to confirm this things.

    A. All your third party extensions compatible with magento 2.4.6-p6

    B. Your Theme is compatible with magento 2.4.6-p6

  2. Try to disable those extension and change theme to magento default luma for cross verification.

  3. Run the following commands from CLI.

    php bin/magento cache:clean
    php bin/magento cache:flush
    php bin/magento indexer:reindex
    php bin/magento setup:upgrade
    php bin/magento setup:static-content:deploy -f
    sudo chmod -R 777 var/ generated/ pub/

@Bhagyesh Bhalodiya


Please flush the redis cache and then execute commands, it will work.

Thank You!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.