Questions tagged [composer-update]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
125 views

How to upgrade Magento clud 2.3.3-p1 to Magento cloud 2.4.4?

I have followed https://magento.stackexchange.com/a/325148/67054 But on composer update step get many errors regarding fastly, cloud-metapackage and framework related. Do I have to switch phpversion ...
user avatar
0 votes
0 answers
63 views

Problem with auth.json and composer update when installing amazon sales channel

Im trying to implement an extension in a Magento project (Amazon sales channel) but when I use the auth.json and I try to 'composer update' im getting this error. Root composer.json requires magento/...
user avatar
1 vote
0 answers
143 views

Composer replace no longer working for Magento Cloud 2.4.3

I was trying to setup a new Magento Cloud 2.4.3 project, and wanted to remove unnecessary module from the installation. I usually use yireo/magento2-replace-all package to clear out some of the module ...
user avatar
0 votes
2 answers
531 views

Failed to upgrade from Magento 2.4.1 to Magento 2.4.3-p1

I'm using magento version 2.4.1 and composer version 1.10.25. i tried to update it to magento 2.4.3-p1 using composer but i always received an error. First i run this command: composer require magento/...
user avatar
  • 79
0 votes
2 answers
163 views

Magento cloud setup install failure

I am trying to install magento in magento cloud. To do so I did: check out https://github.com/magento/magento-cloud setup auth.json setup env:COMPOSER_AUTH in the project with same values stored in ...
user avatar
0 votes
1 answer
39 views

Issue while upgrading the Magento Instance Upgrade

I am currently having the issue, while magento instance upgrade, while running composer upgrade i am having the require resources to be available. But here question is i already having one version of ...
user avatar
0 votes
1 answer
144 views

Upgrade from Magento 2.3.4 to Magento 2.4.3 still shows old version in admin

After upgrading to 2.4.3 (after several issues down the line), the admin still shows the previous version (2.3.4) in the footer, although the CLI version displays 2.4.3. Here are the steps: Using ...
user avatar
0 votes
1 answer
90 views

Upgrading from 2.3.5-p1 to 2.4.3-p1 install issue

When I try to run the composer update. I get this error. elasticsearch/elasticsearch v7.11.0 requires ext-json >=1.3.7 -> the requested PHP extension json has the wrong version (7.4.24) ...
user avatar
0 votes
2 answers
477 views

Update Magento 2.3.0 to 2.4 Error in "Check Component Dependency"

I'm trying to update Magento from 2.3.0 to 2.4 using the setup Wizard. In the Readiness Check, I'm getting the following error: **Check Component Dependency We found conflicting component dependencies....
user avatar
0 votes
1 answer
1k views

No lockfile found. Unable to read locked packages Magento2.4.3 composer update issue

/app/magento2# composer update Loading composer repositories with package information In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate Updating dependencies Nothing to modify in lock ...
user avatar
0 votes
0 answers
80 views

Magento 2: Failed to set PHP CodeSniffer installed_paths Config on upgrade to 2.4.3 from 2.3.0

I am getting this error after running: composer update command: Failed to set PHP CodeSniffer installed_paths Config I tried composer global require "squizlabs/php_codesniffer=*" but still ...
user avatar
1 vote
1 answer
365 views

Getting Conclusion: don't install symfony/console v4.4 while upgrade Magento 2.4.1 from Magento 2.3.3

I am trying to upgrade my Magento 2.3.3 to Magento 2.4.1 running the below commands. 1.composer require magento/composer-root-update-plugin=~1.0 --no-update 2.composer update 3.composer require ...
user avatar
1 vote
2 answers
4k views

Composer can't install any module due to "Your requirements could not be resolved to an installable set of packages"

Running 2.3.6 When I try to install any module via composer I get the following error: []$ COMPOSER_MEMORY_LIMIT=-1 composer require stripe/stripe-php:^7 Warning from https://repo.packagist.org: You ...
user avatar
0 votes
2 answers
473 views

Magento 2.3.5 with cpanel - Unable to downgrade composer to 1.10.20

(Magento 2.3.4) I am trying to downgrade composer due to not being able to run Composer commands as follows. NOTE: from my understanding Magento 2.3 is not compatible with composer 2. composer require ...
user avatar
  • 11
0 votes
2 answers
352 views

unable to update extension from composer

I am trying to update one of my payment gateway extension through composer and the command is composer update razorpay/update But I am getting the below errors Problem 1 - guzzlehttp/guzzle 7.2.0 ...
user avatar
0 votes
1 answer
112 views

Upgrade magento2.3.0 to 2.4.1- allowed memory error

I followed below steps: Part 1: php bin/magento deploy:mode:set developer php bin/magento cache:disable php bin/magento maintenance:enable composer require magento/product-community-edition 2.4.1 --no-...
user avatar
  • 309
0 votes
1 answer
465 views

Magento Commerce Cloud Upgrade 2.4 issue

I am trying to upgrade to Magento 2.4 but I get the following error running composer update: - magento/framework 101.0.0-rc21 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) ...
user avatar
0 votes
1 answer
564 views

how to copy composer install modules of vendor from one project to another project magento 2

Is it possible copy composer install modules of vendor from one project to another project magento 2 without composer commands. If anyone having any idea please guide. I knew that it's not good ...
user avatar
0 votes
1 answer
36 views

Magento 2 Composer install error

The following are causeing PHP version error plz suggest solution
user avatar