0

I am just about to finish my first project with Magento and as always I have crashed something right before the finish line:
I'm using Magento 1.9.0.1 (Community Edition). When I go to Transactional Emails and press the "Add new template" button (I'm sorry for wrong translations, I'm using the German backend (which is quite a mess)) I do not get to the Add template page although it worked yesterday. What I see now is this: Magento error

I am not too experienced with PHP, but my guess is that there might be php Tags missing or a file needed for only this page is missing. I have of course tried googling for the solution but no results.

1

What you are seeing there looks like the file app/code/core/Mage/Core/Model/Email/Template.php.
it can also be located in app/code/local/Mage/Core/Model/Email/Template.php in case you moved it an modified it there.
Anyway, check in those 2 locations and see if the opening php tag is <?php and not <? or if you don't have a closing tag ?> before the first line you see as output.

  • The file seems to be the right one (have not moved or modified it, so it is not in local). But it appears that the php Section ends on every occurence of the ">" sign, no matter if it is inside a comment or not. I do not remember changing anything on this file or relevant to this file – Bernie Aug 5 '14 at 13:48
  • 1
    Well, get a clean copy of it and replace the one you have. – Marius Aug 5 '14 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.