3

I am trying to upgrade magento version from 2.1.9 to 2.1.10

I got following error.

Module 'Magento_Ui' from '/home/zitomer/upgrade.zitomer.com/app/code/Magento/Ui' has been already defined in '/home/zitomer/upgrade.zitomer.com/vendor/magento/module-ui

How to resolve this error as I am not able to upgrade on 2.1.10

  • have you installed Magento 2 Github version? – kunj Sep 25 '18 at 11:39
  • yes.. i have installed git version – 1990rk4 Sep 26 '18 at 5:03
  • so you need to upgrade by git only – kunj Sep 26 '18 at 6:27
0

If you installed M2 via composer you shouldn't have any files in app/code/Magento as the core modules reside in vendor/magento

0

/home/zitomer/upgrade.zitomer.com/app/code/Magento/Ui

navigate there and rename /home/zitomer/upgrade.zitomer.com/app/code/Magento/Ui/composer.json

-->composer.off

/home/zitomer/upgrade.zitomer.com/app/code/Magento/Ui/registration.php

-->registration.off

and try again

as @tecjam said you shouldn't have these files there.. :P

0

You need to delete your core Magento 2 modules from app/code/Magento before deleting those you need run below commands

rm -rf var/view_preprocessed/ var/cache/ var/page_cache/ var/di/ var/tmp/ var/generation/ pub/static/frontend/ app/code/Magento/ vendor/magento

chmod 777 -R *

composer update && composer install

php -f bin/magento setup:static-content:deploy

find . -type d -exec chmod 775 {}

find . -type f -exec chmod 660 {}

chmod u+x bin/magento

bin/magento maintenance:disable

bin/magento cache:clean

Now try again with composer upgate this time Magento will add all modules under vendor/magento folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.