2

I'm getting the following error using Magento 2.1.9:

"Package magento/composer's source key should be specified as {"type": ..., "url": ..., "reference": ...},
{"type":"git","url":"https:\/\/github.com\/magento\/composer.git","reference":null} given.";i:1;s:7856:

I think i mucked up my composer file trying to install a solution for multiple warehouse inventory.

My composer file looks like this:

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.0.13",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.1.9",
    "composer/composer": "@alpha",
    "eadesignro/module-warehouses": "1.0.1"
},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "2.3.*",
    "pdepend/pdepend": "2.2.2",
    "sjparkinson/static-review": "~4.1",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": {
    "0": {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    "sample-module-news": {
        "type": "git",
        "url": "git@github.com:EaDesgin/magento2-warehouses"
    },
    "magento2-warehouses": {
        "type": "git",
        "url": "git@github.com:EaDesgin/magento2-warehouses"
    }
},
"extra": {
    "magento-force": "override"
}

}

Because of this I wasn't able to install new extensions or anything. Thanks for you help in advanced.

0

As it seems that you have updated from 2.0.13 to 2.1.9 maybe you have to apply a patch described here http://devdocs.magento.com/guides/v2.1/release-notes/tech_bull_21-upgrade.html

  • Unfortunately this didn't help. Unless i need to be running some command after I overwrote the files. If not, is there other files that could have been messed with that I could possibly revert back? – aksly Nov 21 '17 at 20:10
0

Your composer.lock file seems to be broken. Can you restore it from version control or backup?

If not, you still have the option to delete it and run a fresh composer install. You might end up with different installed versions of the dependencies than before, but at least Magento itself and the installed extension is specified by exact version in composer.json

  • Hey, sorry this took me so long to reply. I don't have a version that seems to work. When i try composer install , I still get the same error posted at the beginning. Is there some other way i should go about reinstalling composer? As it stands I can't even access the Magento admin panel as it gives me the same error code. Your help is so appreciated and sorry for any novice-esque questions. – aksly Dec 6 '17 at 23:55
0

delete composer.lock and vendor folder and then try composer install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.