0

I'm trying to update magento-2 from 2.1.9 to 2.2. I get the following error:

Source directory /chroot/home/minimoon/staging.ochosbags.com/html/vendor/zendframework/zend-stdlib has uncommitted changes.

How can I fix this?

thanks.

0

If you did not run composer in non-interactive mode, it should give you some options:

  • discard changes
  • stash changes
  • view changes
  • abort

If you are sure, you did not change anything in vendor, you can discard the changes. It might be something irrelevant like changed file permissions.

If you DID change something (which you should never do) and you want to keep the changes, try "stash". The changes will be saved, and git will try to re-apply them after the update.

If you are not sure, view the changes and then decide.

  • it's non-interactive mode. How do I run in in interactive mode? – hezided Oct 7 '17 at 10:32
  • Composer on the command line is interactive by default, it's only non-interactive if you pass the -n or --no-interaction parameter. But it might be that the environment variable COMPOSER_NO_INTERACTION is set. Then you can unset it for one command: COMPOSER_NO_INTERACTION=0 composer update. Or are you using the web installer instead of composer? – Fabian Schmengler Oct 7 '17 at 10:52
  • By the way, here's the documentation for these parameters: getcomposer.org/doc/03-cli.md#composer-no-interaction – Fabian Schmengler Oct 7 '17 at 10:53
  • ohh I see now. Yes I'm using the web installer. Should I use the command line to install? – hezided Oct 7 '17 at 13:02
  • Yes, in the web installer there's no interactive mode. – Fabian Schmengler Oct 7 '17 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.