1

I've imported a copy of the live db to my new dev site using sequel pro. I've had to use this tool as the db has some errors in (duplicate SKU's) and we're trying to fix them, but not on the live server!

I'm not sure what the issue is, but the symptoms are as follows.

http://sitename:8888/admin for the admin login. fill out the username and password. hit login. and it redirects me straight back to the login page.

If I intentionally get the password wrong, it gives me the red error box. So I know I'm geting the password right, because there is no error box. However the admin section doesn't load. Is there an admin setting somewhere in the config stored in the db that I need to reset?.

  • Just a quick one - this happened to me. Turned out the server was out of space... – airdrumz Feb 11 '16 at 17:49
5

This is a very well documented issue - Ashley Schroder put together a great compilation of the well-known issues with admin login problems:

http://www.aschroder.com/2009/05/fixing-magento-login-problem-after-a-fresh-installation/

This is the most common solution, if you have set up Magento to run locally (on MAMP for example) then you may be accessing the Apache webserver using the localhost hostname. A security setting in browsers means that the cookie will not be set, though apparently in FF3 at least, this behavior is a bug?.

So simply stop using localhost, you can use your localhost interface (e.g. 127.0.0.1 or 127.0.1.1). To determine your localhost interface you can look at the contents of your hosts file:

In your case it looks as if you need a "." in the domain name. Some example domains that will work are local.dev, magento.local, 127.0.0.1 - again, anything with a "." in it.

  • 1
    great answer, thanks. I promise I googled the issue, but I obviously didn't use the right keywords. Got the site running with a dotted name in the MAMP config. – bytejunkie Sep 10 '13 at 20:44
1

As philwinkle answered.

But I just wanted to add that not everyone knows how to map local.dev etc. to 127.0.0.1.

To do so, just access your hosts file, on a mac it's at /etc/hosts (I'd recommend to use terminal under root user or sudo nano hosts) or windows at %WinDir%\System32\Drivers\Etc (you'll need to have admin privileges to edit).

Then add a line at the end like: 127.0.0.1 local.dev (or any domain with a dot to prevent the bug).

Note that if you're on a mac behind a proxy (I'm not sure about on windows), you'll need to add the domain and 127.0.0.1:8888 (or whatever your MAMP server uses for the port) to the exceptions for the hosts file to manage the domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.