0

I install Magento about 2-3 weeks ago. I've been using it for a few months in work and decided to start a new project store with it.

Then today i went to login and my username / password appeared to be wrong. I got no errors.. just refreshed to the same login screen.

I thought it might be my password so I did the forgot email thing and got the email to reset my password and I entered a new one and it still won't let me login.

I'm using the same PC as I also do to work. What can be wrong ?

I'm using Magento 1.9.3.7

EDIT-- I just looked at the error logs and this is appearing over and over

    [26-Feb-2018 11:47:01 UTC] PHP Fatal error:  Uncaught exception 'Zend_Db_Adapter_Exception' with message 'The PDO extension is required for this adapter but the extension is not loaded' in /home/*****/**domain**.com/store/lib/Zend/Db/Adapter/Pdo/Abstract.php:344
Stack trace:
#0 /home/*****/**domain**.com/store/lib/Zend/Db/Adapter/Abstract.php(248): Zend_Db_Adapter_Pdo_Abstract->setFetchMode(2)
#1 /home/*****/**domain**.com/store/app/code/core/Mage/Core/Model/Resource.php(175): Zend_Db_Adapter_Abstract->__construct(Array)
#2 /home/*****/**domain**.com/store/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element))
#3 /home/*****/**domain**.com/store/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write')
#4 /home/*****/**domain**.com/store/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write')
#5 /home/*****/**domain**.com/st in /home/*****/**domain**.com/store/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 344
  • Try logging in using private/incognito window. – Vivek Kumar Feb 26 '18 at 12:13
  • I just tried . That didn't work. – DaveYme Feb 26 '18 at 12:15
  • I've added an update from the error logs that may help. – DaveYme Feb 26 '18 at 12:18
  • Is your frontend working? It seems from logs that php has lost write connection to db. – Vivek Kumar Feb 26 '18 at 12:21
  • Yes it's working fine. I'm able to add products to check out etc. – DaveYme Feb 26 '18 at 12:25
1

You need to enable PDO extension from your server.

  • Will this fix my login problem ? .. how was i able to login before ? – DaveYme Feb 26 '18 at 12:40
  • Maybe your web server is working not stable. Because I see in your log. – Vadym Kalin Feb 26 '18 at 16:29
  • My hosting provider says this ""I have checked the PDO extension and saw that it's already enabled for the account. It's not a server side issue, it's purely related to the Magento application and a developer can sort out the issue easily."" --- So i'm not sure where to go now. – DaveYme Feb 27 '18 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.