1

I cant seem to login into my magento 2 backend. When I enter the correct credentials it just redirects me to the login page with no error. Debug, system and exception log are clean. Cache is cleaned already.

Thanks in advance!

  • Have you found a solution for this issue? – Gediminas Jun 22 '17 at 10:33
8

I had the same issue. Solved it by deleting my cookies.

  • After deleting all the cookies in Chrome 61.0.3163.91 I get ERR_TOO_MANY_REDIRECTS. This only happens in Chrome, Firefox works ok. Any idea why? – Andrei Sep 25 '17 at 12:38
0

This issue also shows up when there's an unknown bug in an extension that affects sales display (the dashboard shows sales data). In my case, I just ported an M1 module to M2 using the extremely helpful but seriously flawed Code Migration Toolkit (https://github.com/magento/code-migration). I then ran the command php bin/magento module:enable My_Module and restored my database (migrated from M1 to M2). I couldn't log in so I came across this Stack question and others like it telling me to clear cookies and remove rows from core_config_data. After 1 hour of head scratching, I realized it must be the last thing I did when admin login started to fail. It must be the module that I just enabled. So I disabled it and was able to log in.

Inspecting the code, I came across a configuration file etc/sales.xml that the CMT ported over from M1 to M2. This config file was trying to load a model using the old M1 class name my_module/quote_discount and failing. I commented this out and reenabled the module and was able to log in again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.