0

Issue: The product is not appearing when browsing the catalog from the frontend.

Scenario:

  • Product status is Enabled
  • Product is Salable (In stock)
  • Product is configured under Websites and Categories of the product Edit menu to appear in the specified store views and catalogs.
  • Product is set to Visibility: Catalog,Search

Is there anything else that would affect the product scope?

  • Could you please mention what version of Magento you're using, if you're using flat categories, if you tried to reindex and if there are any 3thparty extensions that might be of influence? – Sander Mangel Aug 8 '13 at 22:01
  • Besides being in stock, also make sure that the quantity is > 0 – David Tay Aug 8 '13 at 22:50
  • I'm using CE 1.7.0.2, there's no option under Product > Inventory to set Qty > 0 for the product. I'm using flat categories I believe. I have reindexed, and I rebuilt my collections cache. I suspected the Qty might be a factor but as I said before, that field does not appear. – DWils Aug 8 '13 at 23:45
  • Does the product appear/is view-able if you access it directly? (either via the url_key, or using direct url of /catalog/product/view/id/<PRODUCT_ID_FROM_ADMIN>) – ProxiBlue Aug 9 '13 at 8:54
  • The issue does appear to be as David Tay suggested, the Qty is 0, however I cannot see any option in the cms to modify the qty directly. – DWils Aug 9 '13 at 22:44
1

Make sure you rebuilt you indexes, and that the products are in stock. If you want out of stock products to appear you need to set this to Yes: System -> Configuration -> Inventory -> Stock Options -> Display Out of Stock Products. A reindex might be required after you change this setting.

  • Thank you for this suggestion, but we are not sure if the client wants out of stock items on the site yet, but they do plan on drop shipping, so this is helpful to know, and may be a valid solution. – DWils Aug 9 '13 at 22:45
0

Look under System Configuration > CATALOG > Inventory and check those settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.