1

I can't seem to get the products showing up on the home page. I keep getting "There are no products matching the selection."

This is what I have tried so far ...

Category ID is 35,

Is Active = Yes,
Show in Nav Bar = No
Display mode = Products & Static Blockx

CMS > Pages > Home > Content >

<div>{{block type="catalog/product_list" template="catalog/product/home.phtml" category_id="35"}}</div> 

There are current 6 products under this category. They all are in stock and show up when browsed via navigation bar. The only issue is that I can't get them listed on the home page.

I have tried searching on Google and Magento forum where people advise re-indexing data etc and I have tried all these but still no luck. What am I doing wrong? Any ideas how can I sort it out?

Thanks for your help.

1

Here are some things to try that will help narrow down the cause of the problem:

  1. Try using the default catalog/product/list.phtml template instead of your custom one
  2. Try a different category or create a new one if necessary

If you post your catalog/product/home.phtml the community may be able to better assist you.

EDIT: The cause of the problem in this case was that the category was either a root category or outside the website/store scope - moving the category inside the current store's default category solved the problem, see comments below.

4
  • yes sure - i will post .../home.phtml in a min..
    – Rambo
    Mar 17 '13 at 22:43
  • Actually I tried changing category ID to a different one as you suggested above and it worked!!!! so seems like problem with the cateogory settings - any ideas what could it be?
    – Rambo
    Mar 17 '13 at 22:46
  • 2
    I have got it sorted!!! actually the category I was trying to show on the home page was out of the ROOT Catalog Category so I just thought to move it inside it and it worked!! thanks for you help anyway..
    – Rambo
    Mar 17 '13 at 22:50
  • I see! Yes if it's a root category or not in the website/store scope then it won't work. Glad you figured it out! Mar 17 '13 at 22:52
0

For me this was eventually a really easy fix!

Try going into product manager and look at the website column.

If there are any not set then hit the select all button, choose the website in the website column drop down then apply it and in the dialog that appears go to the website tab and set the web site in the tree view and save changes.

0

This can also happen if your search engine is set to elastic search and it has a problem. Try to set your search engine to MySQL:

Shops -> Settings: Configuration -> Catalog -> Catalog -> Catalogsearch -> Searchmachine: MySQL

Then start reindexing: php bin/magento indexer:reindex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.