0

I set up my magento 2.3 on localhost via Xampp and all works perfectly. I transferred magento forder and imported the database on server phpmyadmin I changed The core_config_data base URL and edited correctly the env.php informations

When I Search the store address in browser, it redirects me to Localhost (127.0.0.1) If I clean the Var/cache folder, I can finally access to the live store, but all CMS seems to be down and the store frontend aspect completly destroyed.

Any solution for this issue ? is it a matter of htaccess ? Why does the store design turns down each time I clear the cache ? Thank you for your advices

1 Answer 1

0

Try compiling and regenerating static files:

bin/magento setup:upgrade
bin/magento setup:di:compile
bin/magento setup:static-content:deploy -f
bin/magento cache:flush
3
  • Thank you SantiBM, but each time I run the bin/magento setup:di:compile, the store gets down and then impossible to access the store or admin pages. Do you have an explanation for this ? Thank you
    – Vivies
    Jun 15, 2020 at 14:19
  • here error after running command php bin/magento setup:di:compile Fatal error: Uncaught Error: Call to a member function setActive() on bool in C:\xampp\htdocs\magento\vendor\magento\module-backend\Model\View\Result\Page.php:27 Stack trace: #0 ...
    – Vivies
    Jun 15, 2020 at 15:50
  • that error talks about a localhost no? This looks like a windows installation: C:\xampp\ are you sure that error happens on your live server?
    – SantiBM
    Jun 16, 2020 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.