3

I was a regular user of magento 1 month before but now i found difficult to install the magento. Magento is not installing in localhost neither in XAMPP nor in WAMP all the versions and keep on showing the following error:

There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: 142520047

I have tried all the setting options that are present on all the support forums. Please someone help me in finding the solution.

These are the errors in report

a:5:{i:0;s:193:"Error in file: "C:\wamp\www\magento\app\code\core\Mage\Api2\sql\api2_setup\install-1.0.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 La table 'api2_acl_role' existe déjà";i:1;s:912:"#0 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.0.0.0')
#2 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.0.0.0')
#3 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\wamp\www\magento\app\code\core\Mage\Core\Model\App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\wamp\www\magento\app\code\core\Mage\Core\Model\App.php(343): Mage_Core_Model_App->_initModules()
#6 C:\wamp\www\magento\app\Mage.php(683): Mage_Core_Model_App->run(Array)
#7 C:\wamp\www\magento\index.php(87): Mage::run('', 'store')
#8 {main}";s:3:"url";s:44:"/magento/index.php/install/wizard/installDb/";s:11:"script_name";s:18:"/magento/index.php";s:4:"skin";s:7:"default";}
  • goto var/report and check the error in file 142520047 – Dexter Jun 19 '14 at 10:02
  • at what set your getting error – MeenakshiSundaram R Jun 19 '14 at 10:04
  • copy the content of the file 142520047 which is their in the var/report – Pradeep Sanku Jun 19 '14 at 10:04
  • Please tell me how can i solve these errors – Anshul Vyas Jun 19 '14 at 10:11
  • check if all required extensions of magento are enabled in your local setup. – huzefam Jun 19 '14 at 10:17
3

MySQL seems to complain that table or view already exists during install. I would start with wiping the database by dropping all the tables.

  • i also tried this but still there is no effect anyway thanks for the information you shared – Anshul Vyas Jun 19 '14 at 11:01
  • Alright .. the next thing I would check is to make sure that the user has all the necessary permissions to drop and/or alter tables. – Pronto Jun 19 '14 at 11:06
0

Try to rename the file which you got in the error message, like here go to the path

C:\wamp\www\magento\app\code\core\Mage\Api2\sql\api2_setup\install-1.0.0.0.php

and try rename the install-1.0.0.0.php to ~install-1.0.0.0.php and save it and then try installing again.

there will be many file which comes in the process change all the files name like this.

I got the same issue once and I did the same thing. and all work fine for me.

  • it worked fine, because you deactivated all the install/update scripts and had a lot of luck, to not use a single feature of them. Working but very very bad advice – Flyingmana Jun 19 '14 at 10:50
  • the solution is not working either – Anshul Vyas Jun 19 '14 at 10:52
  • Well may be I am lucky in past, but thanks for giving me the advice and cleared the problems which will arise by this. Thanks Flyingmana – Waseem Jun 19 '14 at 10:52
  • AnshulVyas as you have seen its not the proper solution, but are you installing the fresh magento or some backup. – Waseem Jun 19 '14 at 10:57
  • i am installing fresh magento and all the versions that i can find – Anshul Vyas Jun 19 '14 at 11:11
0

Did you check this table?

api2_acl_role

Update the rows in that table as per conditions and requirements, clear cache by going to var/cache.

  • 1
    Are you installing fresh magento or installing magento by using backup DB? – brainReader Jun 19 '14 at 11:04
  • Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.0.0.0')?? Locate this in your DB, update the version. – brainReader Jun 19 '14 at 11:07
0

I got to answer now. I had the same issue and solved it these way:

  • Go to xampp and than click config in Apache row.
  • Open PHP (php.ini) file.
  • Ctrl+F if using english keyboard and find max_execution_time and set it to 3.600 or 0 (0 means infinite)
  • Again Ctrl+F if using english keyboard and find max_input_time and set it equal to 3.600 or 0.
  • Now retry and just wait. It will work.

This happens because Magento need more time to execute all the tables in mysql and by default the max time execution is 30 or 60.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.