1

Today I installed a fresh magento CE 1.9.2 onto a dedicated server (1and1) and ran into an error that I cant get passed.

The initial error is "Exception printing is disabled by default for security reasons. Error log record number: XXXXXXXXXXX". After looking at the error code, I found that "Base table or view not found or doesn't exist"

Error in file: "app/code/core/Mage/Poll/data/poll_setup/data-install-1.6.0.0.php" - SQLSTATE[42S02]: Base table or view not found: 1146 Table 'db583671866.poll' doesn't exist, query was: DESCRIBE poll

Trace:

0 app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')

1 app/code/core/Mage/Core/Model/Resource/Setup.php(391): Mage_Core_Model_Resource_Setup->_modifyResourceDb('data-install', '', '1.6.0.1')

2 app/code/core/Mage/Core/Model/Resource/Setup.php(289): Mage_Core_Model_Resource_Setup->_installData('1.6.0.1')

3 app/code/core/Mage/Core/Model/Resource/Setup.php(269): Mage_Core_Model_Resource_Setup->applyDataUpdates()

4 app/code/core/Mage/Core/Model/App.php(362): Mage_Core_Model_Resource_Setup::applyAllDataUpdates()

5 app/Mage.php(684): Mage_Core_Model_App->run(Array)

6 index.php(83): Mage::run('', 'store')

7 {main}

Other people have had this problem and I've read all the other topics on this but it was a different table that missing so adding their fix wouldn't help. What is the best way to troubleshoot this? Or does anyone know how to fix the issue?

0

Your magento does not install properly.

May be one or more tables has been missing from your database.

You need to reinstall your magento system properly.

May be execution time was exceed during the installation process. For this case you increase max execution time in php.

  • Thanks for your suggestion. I increased max execution time and memory limit with still no fix. I've tried about 5 different fresh installs of the 1.9.1 and the latest 1.9.2. However more recently, the install is stuck on another table, this time. >Base table or view already exists: 1050 Table 'customer_entity' already exists, query was: CREATE TABLE customer_entity ( entity_id int UNSIGNED NOT NULL auto_increment COMMENT 'Entity Id' , Im not sure what else to do. – Brian Jul 14 '15 at 14:16
  • SOLUTION: I increased the max execution like Amit suggested and just tried a bunch of installations. I completed the configuration page and just let it load (waited about 10 minutes). I got a 504 bad gateway error but when i reloaded the page, It was successful. TL:DR just be patient on the installation – Brian Jul 14 '15 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.