1

I have recently migrated my site to a new dedicated server and as part of the move have updated the URL to a new one.

I am getting an invalid URI error and have searched the forums and the wider web but only find references to URLs with underscores in them.

Neither the old URL nor the new URL contain any underscores but I get the following error when trying to access any page:

There has been an error processing your request

Invalid URI supplied

Trace:

#0 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/lib/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '//elmers.unitym...')
#1 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/app/code/core/Mage/Core/Model/Store.php(726): Zend_Uri::factory('http://elmers.u...')
#2 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/app/code/core/Mage/Core/Controller/Varien/Front.php(313): Mage_Core_Model_Store->isCurrentlySecure()
#3 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/app/code/core/Mage/Core/Controller/Varien/Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#4 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#5 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#6 /var/www/vhosts/unitymedia-dev.co.uk/elmers.unitymedia-dev.co.uk/index.php(87): Mage::run('', 'store')
#7 {main}

The url I am trying to set it up on is: http://elmers.unitymedia-dev.co.uk/

I have changed the urls in the core config data table to the new url and checked there are no random spaces or characters, but it still won't have it.

If someone could help it would be really appreciated.

Thanks

0

Can you please open lib/Zend/Uri/Http.php file and add the following lines:

$a = $this->validateUsername();
$b = $this->validatePassword();
$c = $this->validateHost();
$d = $this->validatePort();
$e = $this->validatePath();
$f = $this->validateQuery();
$g =  $this->validateFragment();
var_dump($a, $b, $c, $d, $e, $f, $g);
exit;

above the

// Validate the URI
if ($this->valid() === false) {

And post the output here. This way we can check what part of the url can't pass validation.

Also, could you please tell what the values are for "web/unsecure/base_url" and "web/secure/base_url" in your core_config_data table?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.