2

Please help me guys to fix it :

Fatal error: Class 'Mage_Parcelamento_Helper_Data' not found in C:\wamp64\www\magento\app\Mage.php on line 547

Error log

Warning: include(Mage\Parcelamento\Helper\Data.php): failed to open stream: No such file or directory in lib\Varien\Autoload.php on line 94

2

There are two possibilities:

1) Either you declared your helper in the config.xml and you did not create it in the module NameSpace/NameModule/Helper/Data.php

2) Either you created it in the module but not in the config.xml or you did it wrong.

Solution:

You should have this in your config.xml:

<global>
  ...
    <helpers>
        <parcelamento>
            <class>Namespace_Parcelamento_Helper</class>
        </parcelamento>
    </helpers>
  ...
</global>

You should also have this in :Namespace/Parcelamento/Helper/Data.php

<?php

class Namespace_Parcelamento_Helper_Data extends Mage_Core_Helper_Abstract
{

}

Now you can call your helper like this:

<?php Mage::helper('parcelamento')?>
0

Check in your code you will find code as below

Mage::helper('parcelamento')

Check in your module config file have helper name like bwlow.

<helpers>
    <module>
       <class>Namespace_Module_Helper</class>
    </module>
</helpers>

replace Parcelamento with your helper name

0

To get the website and admin panel live again, I disabled the compilation via SFTP.

You can do that by editing the root/includes/config.php file.

To disable compilation in Magento, edit includes/config.php, comment out the first line (line 28) and uncomment out the second line (line 29).

Your final code should look like this (without brackets):

#define('COMPILER_INCLUDE_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'src');  
#define('COMPILER_COLLECT_PATH', dirname(FILE).DIRECTORY_SEPARATOR.'stat');

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.