0

I applied SUPEE-6788 patch on magento 1.9.1 and now blocks on homepage disappeared. Here https://magentary.com/kb/cms-pages-transactional-emails-broken-after-supee-6788-patch/ they say go to System > Permissions > Blocks menu on admin but there is no such item on my admin menu, only "Users" and "Roles".

  • After applying the patch did you log out and then back in again and clear the cache? That setting should be there – DanCarlyon Aug 12 '16 at 13:46
  • Yes, I did that. Should it be any new sql tables ? Maybe problem with database? Anyway, I revert this patch for now, because it's a live client side and it was scary – Anna Aug 12 '16 at 13:51
  • if you can try it on a local/dev version of the site. Also might be worth checking that the user account your are logged in with has Administrator permissions. Also after applying log into the admin and then check the exception/system logs for any errors, might be something in there – DanCarlyon Aug 12 '16 at 13:54
  • I ended up adding missing block types into permission_block table manually, so now they are visible – Anna Aug 12 '16 at 14:24
  • If that permissions table is there, then it sounds like the reason you can't see the menu item may be down to user permissions :) – DanCarlyon Aug 12 '16 at 14:27
0

Seems like the new files introduced by the patch are not readable. Please check file permissions and ownership in app/code/core/Mage/Admin

Don't forget to clean the cache afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.