0

there are tons of articles about this subject, but it seems that none of them work for me.

I have two magento installations on my server:

domain.com
domain.com/test

On both installations I have the following settings: enter image description here

I set "only use http" to "no", but still the issue exists. I tried to enter "domain.com/test" in the cookie domain section, but after I did this I was not able to login anymore.

In the database I have the following settings:

web/unsecure/base_url -> https://domain.com/test/
web/secure/base_url -> https://domain.com/test/

Does anybody know why the system will not remember the user?

Thanks.

0

domain.com/test isn't a cookie domain domain.com can be one. Try setting the cookie domain to .domain.com But you might have issues as the cookies will be accessible for both magento sites, it would be much simpler to have two actual domain names and then set each site's cookie domain correctly.

2
  • Do I enter test.domain.com without https:// in the cookie domain field? – Torben Aug 25 '15 at 11:49
  • The cookie domain is just the domain so does not include the https:// It would only be test.domain.com if you accessed your second site on this address, you said above you accessed it via domain.com/test so that would make the cookie domain .domain.com – psatek Aug 25 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.