3

I recently set up my store to use an SSL proxy for secure connections.

On Frontend everything works fine since I activated the configuration otion "Use SID in Shop frontend". A session variable is added to each URL and the Session sharing between the proxy and my website works.

As an example the url looks like this:

https://ssl.webpack.de/{{shopname}}/customer/account/login/?SID=6j807xxwgbtvlj1qns3abc1a50

However this does not work for the backend. There is no option to add the SID to admin URLs. Does anyone now how to get the backend working with ssl proxy.

Another option would be to set the cookie correctly for .webpack.de - but whenever Magento tries to set a cookie with the session information, it takes the shopname as Domain. Which is not correct for the secure environment. I am using Magento CE Version 1.7.0.2.

2

it seems your session not set properly for your ssl url,

you check for the cookies that

  1. Ensure you have mod_headers.so enabled in Apache instance

  2. Add following entry in httpd.conf

    Header edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure

  3. Restart Apache Web Server

Note: Header edit is not compatible with lower than Apache 2.2.4 version. You can use following to set HttpOnly and Secure flag in lower than 2.2.4 version. Thanks to Ytse for sharing this information.

Header set Set-Cookie HttpOnly;Secure

Verification:

Open your website with HTTP Watch, Live HTTP Header or HTTP Header Online tool.

Check HTTP response header, you should see as highlighted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.