0
  • Magento 2.2.4
  • Store set up on subdomain: dev.store.com
  • SSL
  • Config variables:

web/unsecure/base_url - https://dev.store.com/

web/unsecure/base_web_url - {{unsecure_base_url}}

web/unsecure/base_link_url - {{unsecure_base_url}}

web/secure/base_url - https://dev.store.com/

web/secure/use_in_frontend -

web/secure/use_in_adminhtml - 1

web/secure/base_web_url - {{secure_base_url}}

web/secure/offloader_header - X-Forwarded-Proto

web/secure/base_link_url - {{secure_base_url}}

I get the admin login page ok. After providing login credentials website gets into a redirection loop. As I can see it's redirected from:

dev.store/com/admin_123/admin/dashboard/index/key/

to

dev.store/com/admin_123/admin/system_account/

Any suggestions, please?

  • Can you check your web/cookie/cookie_path and web/cookie/cookie_domain settings? These should be set to / and your domain respectively (Or adjust path as needed of course). – sduif Jul 16 at 6:59
  • Neither of those exists in my config system. When I try to set them I get "invalid domain name" error – Pete Jaworski Jul 16 at 7:14
  • Is that with the following values? web/cookie/cookie_path = / web/cookie/cookie_domain = dev.store.com – sduif Jul 16 at 7:20
  • I've set it as suggested, but it didn't help... – Pete Jaworski Jul 16 at 7:38
  • Ok, maybe have a look through these answers then: magento.stackexchange.com/questions/90456/… – sduif Jul 16 at 7:44
0

The problem was related with account I was trying to log in with. For some reason Magento didn't like it. I created new admin user and logged in ok with the new one. Just letting you know that it might be worth checking before going any deeper into it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.