1

I'm creating a website for a client, and I ordered a template with demo data from someone in America.

But in the website there is an error. When I logged in in the site as customer and I'm editing my address there is an error:

  • Please enter first name
  • Please enter last name

Although these fields are filled.

Even when you proceed to the basked and paymend through onestep checkout when you fill in your billing information the name is not assiged to the billing and shipping address.

Can somebody please point me in the good direction what to do now?

I'm a developer in .NET so if someone can point me in the good direction of what to do now (in the database or where to look) I will be very thankful.

  • is only name not assign to customer or other information is save? – Amit Bera Feb 7 '15 at 12:48
  • I am traveling.. Let you know – Amit Bera Feb 7 '15 at 13:25
  • K...i will check. Let you know – Amit Bera Feb 7 '15 at 13:38
  • Did you check the site? – Loogie Feb 7 '15 at 19:58
3

Already found the answer myself. This is due to a misconfiguration in the database.

Look in the table customer_eav_attribute. The field is_visible is propably set to 0 where it should be set to 1 for the attributes firstname and lastname. To lookup the ids of the attribute firstname and lastname you have to browse the table eav_attribute and look for the records with entity_type_id equals 2 and name equals 'firstname' cq 'lastname'.

For example in my database these are 19 and 21, see next part of sql-script beneath:

---- partial script of eav_attribute table -----
(19, 2, 'firstname', NULL, NULL, 'varchar', NULL, NULL, 'text', 'First Name', NULL, NULL, 1, 0, NULL, 0, NULL),
(20, 2, 'middlename', NULL, NULL, 'varchar', NULL, NULL, 'text', 'Middle Name/Initial', NULL, NULL, 0, 0, NULL, 0, NULL),
(21, 2, 'lastname', NULL, NULL, 'varchar', NULL, NULL, 'text', 'Last Name', NULL, NULL, 1, 0, NULL, 0, NULL),  
....

Just change the is_visible value to 1 for the corresponding records matching the attribute_id in the table customer_eav_attribute and your problem is gone.

Hope this will help you.

Kind regards,

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.