0

I'm trying to install default Magento 2.2.4 version on xampp. on step 6 (last step) I'm getting this error:

[ERROR] LogicException: Unknown module in the requested list: 'Magento_BundleSampleData' in C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\setup\src\Magento\Setup\Model\Installer.php:430 Stack trace: #0 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\setup\src\Magento\Setup\Model\Installer.php(389): Magento\Setup\Model\Installer->readListOfModules(Array, Array, 'enable_modules') #1 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\setup\src\Magento\Setup\Model\Installer.php(334): Magento\Setup\Model\Installer->createModulesConfig(Array, true) #2 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\setup\src\Magento\Setup\Controller\Install.php(109): Magento\Setup\Model\Installer->install(Array) #3 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-mvc\src\Controller\AbstractActionController.php(84): Magento\Setup\Controller\Install->startAction() #4 [internal function]: Zend\Mvc\Controller\AbstractActionController->onDispatch(Object(Zend\Mvc\MvcEvent)) #5 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-eventmanager\src\EventManager.php(490): call_user_func(Array, Object(Zend\Mvc\MvcEvent)) #6 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-eventmanager\src\EventManager.php(260): Zend\EventManager\EventManager->triggerListeners('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) #7 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-mvc\src\Controller\AbstractController.php(118): Zend\EventManager\EventManager->triggerEventUntil(Object(Closure), Object(Zend\Mvc\MvcEvent)) #8 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-mvc\src\DispatchListener.php(118): Zend\Mvc\Controller\AbstractController->dispatch(Object(Zend\Http\PhpEnvironment\Request), Object(Zend\Http\PhpEnvironment\Response)) #9 [internal function]: Zend\Mvc\DispatchListener->onDispatch(Object(Zend\Mvc\MvcEvent)) #10 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-eventmanager\src\EventManager.php(490): call_user_func(Array, Object(Zend\Mvc\MvcEvent)) #11 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-eventmanager\src\EventManager.php(260): Zend\EventManager\EventManager->triggerListeners('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) #12 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\vendor\zendframework\zend-mvc\src\Application.php(340): Zend\EventManager\EventManager->triggerEventUntil(Object(Closure), Object(Zend\Mvc\MvcEvent)) #13 C:\newxampp\htdocs\magento2\Magento-CE-2.2.4-2018-05-01-09-28-45\setup\index.php(35): Zend\Mvc\Application->run() #14 {main}

also, I have tried to install different Magento 2 theme and it's showing me the same error on the console log.

  • From where you have downloaded the Magento 2.2.4 zip? – Sukumar Gorai Jul 23 '18 at 12:43
  • @SukumarGorai i downloaded it from magento.com – jacob15 Jul 23 '18 at 12:47
  • Clear the browser cache and try again. – Sukumar Gorai Jul 23 '18 at 12:49
  • Try one of this: 1. bin/magento setup:uninstall (do backup if you have any data in database that you need) 2. Run installer in incognito window 3. Restart server – BartZalas Jul 23 '18 at 12:58
0

It was only browser cache, just change the browser . If not working then use incognito browser. it's not mandatory but ones restarting MySQL or Apache has fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.